Can't boot with USB stick no Lenovo Yoga C640 C640-13IML

I recently installed Manjaro KDE(plasma) on my Desktop and love it

I wanted to install Manjaro XFCE or Mangaro KDE on my Lenovo Yoga C640 C640-13IML Laptop and can’t boot the USB stick.

This Laptop BIOS doesn’t allow me to set it in legacy mode. I can though, turn on and off the SafeMode but it doesn’t help. Yes I choose the BOS menu (boot menu) and choose the USB stick but it doesn’t recognize it.

Whatever I do in the BIOS the USB stick is unbootable… a WIndows USB stick will boot

For I don’t know which reason, I tried Garuda KDE ( arch based) and it booted with the USB stick without any problem…

Does anyone have a guess why Garuda KDE ( dragonized version) based on arch would boot from an installation USB stick and not Manjaro KDE (or XFCE)

I don’t like that Laptop Bios but I’m stucked with it…
tks !

You dont want to.

SafeBoot or similar will need to be off.

Have you checked the USB on anything else? Is it the same as previously used?

One thought could be age - if the Manjaro ISO is somewhat old (and the included kernel, etc) in comparison to other ISOs that could be whats stopping you.

If you can boot other Linux ISOs I would guess its not a problem of a bad BIOS setting.

1 Like


Yes safeBoot off

I download the last ISO from this site ( XFCE and KDE).

I will try the USB stick on another PC tomorrow. I tried different usb stick (3)

Tks !!

I would prefer Manjaro KDE or XFCE than Garuda…

will let you know tomorrow how it’s going…

You dont need to tell me twice. Garuda was made by a previous user of this forum. :wink:

1 Like

The usb creation mode should match the boot mode. You cannot boot bios usb on uefi and vice versa.

WOW you’re the 1st to tell me this, I didn’t know.

I usually use etcher (default settings), I will try to see if i can tweak something or use a different tool…

Balena etcher did the job in my case.

!!! If you knew how much time I lost with that yesterday and endedup installing another distro and I wanted KDE or XFCE ( Manjaro)

The worst student are IT people LOL I wasn’t sure about your suggestiong but just burned my XFCE with RUFUS on my Wife DEsktop and it’s working !! I can now boot my Lenovo Yoga with Manjaro !!!


I used Rufus Default…

both suck. use ventoy

1 Like

Balena on Windows or Balena Etcher on a Linux Host ? I am curious

Trying Ventoy, can we burn an ISO with that ?? It seem a formatting tool only… Will continue testing

ventoy needs to format the USB stick. It will then create two partitions — one for itself and one for the ISOs. You then simply drag & drop the ISOs onto the second partition as files. ventoy will recognize them and offer you a menu from which you can boot the ISOs directly.

1 Like

It was a new laptop and it had only windows on it (but there is an appimage too). But i have used rufus too, with variable success. I now use ventoy, ventoy adds another layer/chainload on booting, which is not liked by some old selfextracting antivirus iso-s for example (they look for the kernel in the wrong path then). Have not tried the combo ventoy+manjaro iso.

1 Like

Manjaro + ventoy works for me on Lenovo Yoga S740-14IIL

1 Like

This topic was automatically closed 3 hours after the last reply. New replies are no longer allowed.