Cant boot to LTS or other Kernel

Hello, noob here.

I got a new laptop and installed Manjaro (coming from Ubuntu). One of the first things I wanted to do was switching to the LTS Kernel. So I installed it, rebooted and selected it. But then: nothing. First only the manufactors logo for a long time and then a black screen. Uninstalled it, reinstalled it, tried other Kernels. Everytime the same.

So I can only boot from the Kernel that was installed in the beginning.

Also (dont know if it has something to do with it) I tried to boot POP OS via USB and again it wouldnt boot (booted normally on my other pc). But the Manjaro USB is booting normally into Live OS.

In between (after my first attemt of switching to other Kernel) I also had an Error, I dont remember what it exactly was (I had so many problems, so I dont remember everything now…) but I had to deactivate secure booting. (also dont know, if it could have something to do with it…)

I have no idea what information I can give you other then:

uname -r

Post the output of this

inxi --admin --verbosity=7 --filter --no-host --width

  Kernel: 5.9.16-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.1 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.9-x86_64 
  root=UUID=ccd8070b-1862-4ef6-9058-f9aea870dedc ro quiet apparmor=1 
  security=apparmor resume=UUID=40acc7cf-e697-4752-8654-6a1bacc294eb 
  Desktop: KDE Plasma 5.21.1 tk: Qt 5.15.2 wm: kwin_x11 dm: SDDM 
  Distro: Manjaro Linux 
  Type: Laptop System: Schenker product: XMG CORE 17(M20, RTX 2060) 
  v: Standard serial: <filter> 
  Mobo: Schenker model: GK7NxxR M20 v: Standard serial: <filter> 
  UEFI: American Megatrends v: N.1.16.A01 date: 09/02/2020 
  ID-1: BAT0 charge: 26.2 Wh condition: 62.3/62.3 Wh (100%) volts: 16.1/15.2 
  model: standard type: Li-ion serial: <filter> status: Charging 
  RAM: total: 15.12 GiB used: 3.05 GiB (20.2%) 
  RAM Report: permissions: Unable to run dmidecode. Root privileges required. 
  Info: 8-Core model: AMD Ryzen 7 4800H with Radeon Graphics bits: 64 
  type: MT MCP arch: Zen 2 family: 17 (23) model-id: 60 (96) stepping: 1 
  microcode: 8600103 L2 cache: 4 MiB bogomips: 92663 
  Speed: 1591 MHz min/max: 1400/2900 MHz boost: enabled Core speeds (MHz): 
  1: 1591 2: 1707 3: 1454 4: 1588 5: 3342 6: 2367 7: 1642 8: 1555 9: 1912 
  10: 2022 11: 1725 12: 1899 13: 1592 14: 1449 15: 1533 16: 1570 
  Flags: 3dnowprefetch abm adx aes aperfmperf apic arat avic avx avx2 bmi1 
  bmi2 bpext cat_l3 cdp_l3 clflush clflushopt clwb clzero cmov cmp_legacy 
  constant_tsc cpb cpuid cqm cqm_llc cqm_mbm_local cqm_mbm_total cqm_occup_llc 
  cr8_legacy cx16 cx8 de decodeassists extapic extd_apicid f16c flushbyasid 
  fma fpu fsgsbase fxsr fxsr_opt ht hw_pstate ibpb ibrs ibs irperf lahf_lm 
  lbrv lm mba mca mce misalignsse mmx mmxext monitor movbe msr mtrr mwaitx 
  nonstop_tsc nopl npt nrip_save nx osvw overflow_recov pae pat pausefilter 
  pclmulqdq pdpe1gb perfctr_core perfctr_llc perfctr_nb pfthreshold pge pni 
  popcnt pse pse36 rdpid rdpru rdrand rdseed rdt_a rdtscp rep_good sep sha_ni 
  skinit smap smca smep ssbd sse sse2 sse4_1 sse4_2 sse4a ssse3 stibp succor 
  svm svm_lock syscall tce topoext tsc tsc_scale umip v_vmsave_vmload vgif 
  vmcb_clean vme vmmcall wbnoinvd wdt xgetbv1 xsave xsavec xsaveerptr xsaveopt 
  Vulnerabilities: Type: itlb_multihit status: Not affected 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, IBRS_FW, 
  STIBP: conditional, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
  Device-1: NVIDIA TU106M [GeForce RTX 2060 Mobile] 
  vendor: Tongfang Hongkong Limited driver: nvidia v: 460.39 
  alternate: nouveau,nvidia_drm bus ID: 01:00.0 chip ID: 10de:1f15 
  class ID: 0300 
  Device-2: AMD Renoir vendor: Tongfang Hongkong Limited driver: amdgpu 
  v: kernel bus ID: 05:00.0 chip ID: 1002:1636 class ID: 0300 
  Device-3: Chicony HD Webcam type: USB driver: uvcvideo bus ID: 3-4:4 
  chip ID: 04f2:b641 class ID: 0e02 
  Display: x11 server: X.Org 1.20.10 compositor: kwin_x11 driver: 
  loaded: modesetting,nvidia display ID: :0 screens: 1 
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 506x285mm (19.9x11.2") 
  s-diag: 581mm (22.9") 
  Monitor-1: HDMI-0 res: 1920x1080 dpi: 48 size: 1020x570mm (40.2x22.4") 
  diag: 1168mm (46") 
  OpenGL: renderer: GeForce RTX 2060/PCIe/SSE2 v: 4.6.0 NVIDIA 460.39 
  direct render: Yes 
  Device-1: AMD Family 17h HD Audio vendor: Tongfang Hongkong Limited 
  driver: snd_hda_intel v: kernel bus ID: 05:00.6 chip ID: 1022:15e3 
  class ID: 0403 
  Sound Server: ALSA v: k5.9.16-1-MANJARO 
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Tongfang Hongkong Limited driver: r8169 v: kernel port: e000 
  bus ID: 02:00.0 chip ID: 10ec:8168 class ID: 0200 
  IF: enp2s0 state: down mac: <filter> 
  Device-2: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel port: e000 
  bus ID: 03:00.0 chip ID: 8086:2723 class ID: 0280 
  IF: wlo1 state: up mac: <filter> 
  IP v4: <filter> type: dynamic noprefixroute scope: global 
  broadcast: <filter> 
  IP v6: <filter> type: dynamic noprefixroute scope: global 
  IP v6: <filter> type: noprefixroute scope: link 
  WAN IP: <filter> 
  Device-1: Intel AX200 Bluetooth type: USB driver: btusb v: 0.8 bus ID: 5-4:3 
  chip ID: 8087:0029 class ID: e001 
  Message: Required tool hciconfig not installed. Check --recommends 
  Message: No RAID data was found. 
  Local Storage: total: 465.76 GiB used: 206.47 GiB (44.3%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Kingston model: SA2000M8500G 
  size: 465.76 GiB block size: physical: 512 B logical: 512 B speed: 31.6 Gb/s 
  lanes: 4 rotation: SSD serial: <filter> rev: S5Z42105 temp: 25.9 C 
  scheme: GPT 
  Message: No Optical or Floppy data was found. 
  ID-1: / raw size: 292.65 GiB size: 287.05 GiB (98.09%) 
  used: 206.46 GiB (71.9%) fs: ext4 dev: /dev/nvme0n1p2 maj-min: 259:2 
  label: N/A uuid: ccd8070b-1862-4ef6-9058-f9aea870dedc 
  ID-2: /boot/efi raw size: 300 MiB size: 299.4 MiB (99.80%) 
  used: 312 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1 label: N/A 
  uuid: 0662-C784 
  ID-3: /run/timeshift/backup raw size: 292.65 GiB size: <superuser required> 
  used: <superuser required> fs: ext4 dev: /dev/nvme0n1p2 maj-min: 259:2 
  label: N/A uuid: ccd8070b-1862-4ef6-9058-f9aea870dedc 
  Kernel: swappiness: 60 (default) cache pressure: 100 (default) 
  ID-1: swap-1 type: partition size: 16.64 GiB used: 2.5 MiB (0.0%) 
  priority: -2 dev: /dev/nvme0n1p3 maj-min: 259:3 label: N/A 
  uuid: 40acc7cf-e697-4752-8654-6a1bacc294eb 
  ID-1: /dev/nvme0n1p4 maj-min: 259:4 size: 156.18 GiB fs: ext4 label: N/A 
  uuid: 6a3644b6-cf80-4778-829b-2a9e48764ded 
  Hub-1: 3-0:1 info: Full speed (or root) Hub ports: 4 rev: 2.0 
  speed: 480 Mb/s chip ID: 1d6b:0002 class ID: 0900 
  Device-1: 3-1:2 info: Realtek RTS5129 Card Reader Controller 
  type: <vendor specific> driver: rtsx_usb,rtsx_usb_ms,rtsx_usb_sdmmc 
  interfaces: 1 rev: 2.0 speed: 480 Mb/s chip ID: 0bda:0129 class ID: ff00 
  serial: <filter> 
  Hub-2: 3-2:3 info: Genesys Logic Hub ports: 2 rev: 2.1 speed: 480 Mb/s 
  chip ID: 05e3:0610 class ID: 0900 
  Device-1: 3-2.1:7 info: Microsoft Natural Ergonomic Keyboard 4000 V1.0 
  type: Keyboard,HID driver: microsoft,usbhid interfaces: 2 rev: 2.0 
  speed: 1.5 Mb/s chip ID: 045e:00db class ID: 0300 
  Device-2: 3-2.2:6 info: MosArt 2.4G Keyboard Mouse type: Keyboard,Mouse 
  driver: hid-generic,usbhid interfaces: 2 rev: 1.1 speed: 12 Mb/s 
  chip ID: 062a:4182 class ID: 0301 
  Device-3: 3-4:4 info: Chicony HD Webcam type: Video driver: uvcvideo 
  interfaces: 2 rev: 2.0 speed: 480 Mb/s chip ID: 04f2:b641 class ID: 0e02 
  Hub-3: 4-0:1 info: Full speed (or root) Hub ports: 2 rev: 3.1 speed: 10 Gb/s 
  chip ID: 1d6b:0003 class ID: 0900 
  Hub-4: 4-2:2 info: Genesys Logic USB3.2 Hub ports: 2 rev: 3.2 speed: 5 Gb/s 
  chip ID: 05e3:0620 class ID: 0900 
  Hub-5: 5-0:1 info: Full speed (or root) Hub ports: 4 rev: 2.0 
  speed: 480 Mb/s chip ID: 1d6b:0002 class ID: 0900 
  Hub-6: 5-3:2 info: Genesys Logic Hub ports: 4 rev: 2.0 speed: 480 Mb/s 
  chip ID: 05e3:0608 class ID: 0900 
  Device-1: 5-4:3 info: Intel AX200 Bluetooth type: Bluetooth driver: btusb 
  interfaces: 2 rev: 2.0 speed: 12 Mb/s chip ID: 8087:0029 class ID: e001 
  Hub-7: 6-0:1 info: Full speed (or root) Hub ports: 2 rev: 3.1 speed: 10 Gb/s 
  chip ID: 1d6b:0003 class ID: 0900 
  System Temperatures: cpu: 49.4 C mobo: N/A 
  Fan Speeds (RPM): N/A 
  GPU: device: nvidia screen: :0.0 temp: 41 C device: amdgpu temp: 38.0 C 
  Processes: 354 Uptime: 6h 43m wakeups: 10 Init: systemd v: 247 Compilers: 
  gcc: 10.2.0 Packages: pacman: 1411 lib: 411 flatpak: 0 Shell: Bash v: 5.1.0 
  running in: konsole inxi: 3.3.01 
In [Morsezeichen]( wird J *kurz, lang, lang, lang*, also **· − − −** geschrieben/gesprochen.``

Have u tried installing Linux 5.11 and 5.10 LTS kernels?

And yes u need to disable secure boot to use Manjaro

1 Like

hmm no, its not showing the tls flag…? The latests LTS I see is the 5.4
But ok, Ill try and report

5.10 is the latest LTS kernel
For amd CPUs there is a performance improvement with kernel 5.11…so u might want to use that and keep the 5.10 LTS kernel as a fallback

Thank you! That indeed worked!
Why wasnt it working with the others and now it did??
Nonetheless, Thanks a lot!

1 Like

Welcome.Glad it worked… sometimes old kernels don’t work with newer hardware…

1 Like

U can check kernel development status here

1 Like

Some hardware won’t boot with specific kernels as there is no support for them in those older kernels. For example, I cannot boot into Kernel 5.4 with my Radeon RX 5700XT, but I can in Kernel 5.6 and onward (but much much better with Kernel 5.10 and 5.11 now)

Some stuff are backported to some LTS kernels, but not everything.

If you want to learn more about each kernel changes, you can check it out here:

Phoronix has some good outlines as well


Ok, thank you! I will check out the links :slight_smile:

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.