Can't boot since new update

Hey guys!

So I have been using Manjaro for half a year now on VMware Player 16 without any problems. Today I update the virtual machine since I was behind for like a month. The update finished without errors and prompted me to a restart which I did, but the system never booted up again. I was trying to save the work that I had on it by using chroot from a live boot. I did a pacman mirror-list -f and an update. Also tried to update grub. Nothing worked so I gave up and tried reinstalling from a freshly downloaded ISO.

This didn’t go well either, when trying to live boot it always got hung up on “A start job is running for LiveMedia MHWD Script”. Again I tried a lot of stuff, spent a few hours on it. Changing “driver=free” to “driver=intel” worked, which is weird because my laptop can only use the nvidia gpu(it’s not a max-q). So after installing and trying to boot it, I am back to where I started: a black screen after the Manjaro loading screen.

I tried using an older version, I installed and booted version 19 without any problems.

1 Like

Welcome at the forum, @megaphag

Please post

inxi -Fazy

I used live boot, this time with “driver=mesa”, then “manjaro-chroot -a”

  12Kernel 5.10.30-1-MANJARO x86_64 12bits 64 12compiler gcc 12v 10.2.0 
  12parameters BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=en_US keytable=us tz=UTC 
  misobasedir=manjaro misolabel=MANJARO_GNOME_2102 quiet systemd.show_status=1 
  driver=mesa nouveau.modeset=1 i915.modeset=1 radeon.modeset=1 
  12Console N/A 12wm gnome-shell 12Distro Manjaro Linux 12base Arch Linux 
  12Type Vmware 12System VMware 12product VMware Virtual Platform 12v N/A 
  12serial <filter> 12Chassis No Enclosure 12type 1 12serial N/A 
  12Mobo Intel 12model 440BX Desktop Reference Platform 12serial N/A 12BIOS Phoenix 
  12v 6.00 12date 07/22/2020 
  12Info 4x Single Core 12model Intel Core i7-8750H 12bits 64 12type SMP 
  12arch Kaby Lake 12note check 12family 6 12model-id 9E (158) 12stepping A (10) 
  12microcode B4 12cache 12L1 8 MiB 12L2 36 MiB 
  12flags avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 12bogomips 17663 
  12Speed 2208 MHz 12min/max N/A 12base/boost 2200/30000 12volts 3.3 V 
  12Core speeds (MHz) 121 2208 122 2208 123 2208 124 2208 
  12Vulnerabilities 12Type itlb_multihit 12status KVM: VMX unsupported 
  12Type l1tf 12mitigation PTE Inversion 
  12Type mds 12mitigation Clear CPU buffers; SMT Host state unknown 
  12Type meltdown 12mitigation PTI 
  12Type spec_store_bypass 
  12mitigation Speculative Store Bypass disabled via prctl and seccomp 
  12Type spectre_v1 
  12mitigation usercopy/swapgs barriers and __user pointer sanitization 
  12Type spectre_v2 12mitigation Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: disabled, RSB filling 
  12Type srbds 12status Unknown: Dependent on hypervisor status 
  12Type tsx_async_abort 12status Not affected 
  12Device-1 VMware SVGA II Adapter 12driver vmwgfx 12v 12bus-ID 00:0f.0 
  12chip-ID 15ad:0405 12class-ID 0300 
  12Display 12server 1.20.11 12compositor gnome-shell 12driver 12loaded vmwgfx 
  12note n/a (using device driver) 12unloaded modesetting 
  12alternate fbdev,vesa,vmware 12resolution <missing: xdpyinfo> 
  12Message Advanced graphics data unavailable for root. 
  12Device-1 Ensoniq ES1371/ES1373 / Creative Labs CT2518 12driver snd_ens1371 
  12v kernel 12bus-ID 02:02.0 12chip-ID 1274:1371 12class-ID 0401 
  12Sound Server-1 ALSA 12v k5.10.30-1-MANJARO 12running yes 
  12Sound Server-2 JACK 12v 0.125.0 12running no 
  12Sound Server-3 PulseAudio 12v 14.2 12running yes 
  12Sound Server-4 PipeWire 12v 0.3.25 12running no 
  12Device-1 Intel 82371AB/EB/MB PIIX4 ACPI 12vendor VMware Virtual Machine 
  12type network bridge 12driver N/A 12modules i2c_piix4 12port 1060 12bus-ID 00:07.3 
  12chip-ID 8086:7113 12class-ID 0680 
  12Device-2 Intel 82545EM Gigabit Ethernet 
  12vendor VMware PRO/1000 MT Single Port 12driver e1000 12v kernel 12port 2000 
  12bus-ID 02:01.0 12chip-ID 8086:100f 12class-ID 0200 
  12IF ens33 12state up 12speed 1000 Mbps 12duplex full 12mac <filter> 
  12Device-1 VMware Virtual Bluetooth Adapter 12type USB 12driver btusb 12v 0.8 
  12bus-ID 2-2.1:4 12chip-ID 0e0f:0008 12class-ID e001 12serial <filter> 
  12Report rfkill 12ID hci0 12rfk-id 0 12state up 12address see --recommends 
  12Local Storage 12total 32 GiB 12used 6.89 GiB (21.5%) 
  12SMART Message Required tool smartctl not installed. Check --recommends 
  12ID-1 /dev/sda 12maj-min 8:0 12vendor VMware 12model Virtual S 12size 32 GiB 
  12block-size 12physical 512 B 12logical 512 B 12serial N/A 12rev 1.0 
  12ID-1 / 12raw-size 23.2 GiB 12size 22.66 GiB (97.71%) 12used 6.89 GiB (30.4%) 
  12fs ext4 12block-size 4096 B 12dev /dev/sda1 12maj-min 8:1 
  12Alert No swap data was found. 
  12Message No sensor data found. Is lm-sensors configured? 
  12Processes 251 12Uptime 1m 12wakeups 99 12Memory 7.74 GiB 12used 1.68 GiB (21.7%) 
  12Init systemd 12v 247 12tool systemctl 12Compilers 12gcc N/A 12Packages 12pacman 1114 
  12lib 283 12flatpak 0 12Client Unknown Client: systemd 12inxi 3.3.04

megaphag, how did you generate that inxi report? Somehow the color codes weren’t removed, which can’t happen in any normal way of generating the data, redirect to file, > report.txt removes them, copying from terminal to file manually removes them, piping output removes them. Do you remember what you did there?

  1. What’s the output of inxi --admin --verbosity=7 --filter --no-host --width in the working version?

  2. And you probably didn’t clone it first?

    • If you did, what’s the output of pamac upgrade?
  3. Officially, VMWare doesn’t support Arch distros, you are aware of that, right?