Can't boot: /sbin/init exists but couldn't execute it (error -13)

During the last update I read some “device out of space” (or something like that) errors, i think during kernel updates, but both my root and boot devices had a lot of free space.
When I rebooted, I just got a black screen after grub. I removed the quiet option and I got a

Failed to execute /init (error -13)
Starting init: /sbin/init exists but couldn't execute it (error -13)

error, then a kernel panic, as you can see in the attached pictures.

I have Kubuntu installed on the same machine. What can I do to repair Manjaro?

I have found this: [SOLVED] Kernel panic after latest upgrades / Newbie Corner / Arch Linux Forums

I chrooted into Manjaro, installed a different kernel version (I had to use pacman -S, mhwd-kernel gave me an error about no package selected) and reinstalled grub.
After that, I can boot into Manjaro with the newly installed kernel but booting the old ones still gives the same error.

So boot into Manjaro with the working kernel and reinstall the non-working one.

This worked.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.