Can't boot past motherboard logo (neither kernel 5.9.16 nor 5.10.2) after 12-30-20 update

Updated last night, restarted, and cannot boot past my motherboard’s logo - hangs there indefinitely after selecting my Manjaro drive from GRUB. The update transitioned me to 5.9.16. I installed 5.10.2 to see if that would help - no change. I ran mwhd and have the following (apologies for the lack of columns; I’m typing manually from a separate computer):

video-nvidia 2020.11.30
video-nvidia-390xx 2020.11.30
video-linux 2018.05.04
video-modesetting 2020.01.13
video-vesa 2017.03.12

I queried for old drivers and I appear to have some of them:

nvidia-450xx-utils 450.80.02-1
lib-32-nvidia-utils 455.45.01-3

And do not have linux59-nvidia or linux510-nvidia.

I’m assuming these drivers are the problem. Are the old drivers I listed above the only two I need to remove, or are there others? Which do I need to install? I’d prefer to use 5.10 as it is LTS. Any guidance is greatly appreciated!

Coming from kernel 5.8
Kernel 5.9.16 and 5.10.2 installed
NVIDIA GPU: Gigabyte GTX 770
Have updated my mirror list and the system with sudo pacman-mirrors && sudo pacman -Syyu

Did you tried it with linux54?

Yes, I installed linux54 and tried to boot from that kernel, no dice.

can you boot and open TTY ( Ctrl+ Alt +Fn )
or use USB iso manjaro

sudo mhwd-kernel -li
sudo mhwd -li
sudo ls /etc/mkinitcpio.d/*.preset

I have a similar issue but I’m running the 5.10 kernel.

Here is my output (attempt boot into 5.9.16)

can you apply

sudo pacman -Syy
sudo mhwd -a pci nonfree 0300

Conflicting dependencies error - do I need to remove old packages manually, and if so, which ones?

pacman -Qs nvidia

(Sorry these are all pictures, can’t copy/paste)

sudo pacman -S  linux510-nvidia linux59-nvidia
sudo mkinitcpio -P

Did both of these things, installing linux510-nvidia and linux59-nvidia had me remove an nvidia 455 package (I’m assuming this conflict was the issue and not having the new kernel nvidia packages.)

Am I good to reboot?

Edit: running sudo mkinitcpio -P successfully created an image for my installed kernels.

then reboot

This worked! Thank you stephane!

Edit: I booted into 5.9.16, will try 5.10 just to be sure.

you can remove 5.9 after

Thanks, I think I will. I can boot into 5.9 and 5.10, just not 5.4 - but I don’t plan on using 5.4 anyway. Thank you again!

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.