Can't boot Manjaro Cinnamon from USB stick (Kernel panic - not syncing: No working init found)

Hi, I was trying to get Manjaro Cinnamon (Link to where I installed from) to boot from an USB stick this morning, but failed to because of an error. Here’s the full stack:

[ 0.899363) Initranfs unpacking failed: X2-compressed data is corrupt
[ 1.077294] Kernel panic - not syncing: No working init found. Try passing init= option to kernel. See Linux Documentation/a
dnin-guide/init.rst for guidance.
1.078194) CPU: O PID: 1 Comm: swapper/ Not tainted 5.10.42-1-MANJARO #1
[ 1.078208) Hardware name: LENOVO ZOMFOOOBUS/ZOMFOOOBUS, BIOS NZEET54W (1.36 ) 05/05/2021
[ 1.078224] Call Trace:
1.078235) dump_stack Ox6b/x83
[ 1.073213) ? rest init+0x50/xbe
1.078253) panic+ x108/Oxzde
[ 1.078261) ? kernel execue+OX137/oxlbo
[ 1.078270) ? rest_init+Oxbe/Oxbe
[ 1.078278) kernel_init+0x106/0x112
[ 1.078299) ret_from_fork+x22/0x30
[ 1.078364) Kernel Offset: 0x11200000 from Oxffffffff81000000 (relocation range: Oxffffffff80000000-oxfi ffbfffffff)
[ 1.078387] ---[ end Kernel panic - not symcing: No working init found.
not syncing: No working init found. Try passing init= option to kernel. See Linux Docune
ntation/admin-guide/init.rst for guidance. ]---

Manjaro Deepin worked from an USB drive, but not Cinnamon. I have tried reinstalling the ISO (followed wiki guide), but no luck. Can anyone help me out and debug this issue?

It clearly says the reason for the problem. The initramfs can not be decompressed while booting because it is corrupt.

It is this file: /boot/initramfs-5.10-x86_64

  1. Flash Drive is broken.
  2. ISO is corrupt. Check the ISO with SHA1 Checksum or the GPG Signature.
  3. Download it with Bittorrent (torrent has its own health check of chunks).

Right, I’ll try the bittorrent download.

Used Bittorent for download of Manjaro Cinnamon. Now I get
error: Invalid arch-independent ELF magic.
I am not sure why you suggest that my USB is faulty, when I have booted other OS’s from it just a day prior.

Then the ISO is somehow internally broken. This error refers to grub.

By doing what?

What guide?

Did you verify the checksums of the ISO?

What did you create the USB with? Ventoy to Etcher are the best cross-platform options.


Thank you, using Etcher resolved my issue here. Following the wiki here for burning an ISO doesn’t work with Cinnamon on 2 different machines, that’s a shame though. But that’s probably me misunderstanding something.

Thanks again!

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.