Cant boot into windows 10 after installing manjaro i can boot into manjaro but not windows

i’m running into a problem after installing manjaro i was using kali linux and windows 10 before and i think by mistake i deleted the grub for windows and kali i have tried many times to restore the grub with manjaro i ran into a black screen all the time after that i manged to do it and reinstalled manjaro and i made the grub work i can see manjaro and windows 10 there but when i try to choose windows and try to log into windows it brings me back to the bootloader i can log into manjaro but not windows 10 please can someone one help me

sda      8:0    0 447.1G  0 disk 
├─sda1   8:1    0  86.5G  0 part /run/media/silver/0A6248FD6248EF4F
├─sda2   8:2    0  35.2G  0 part /
├─sda3   8:3    0   321G  0 part /run/media/silver/SSD DATA
├─sda4   8:4    0     8M  0 part 
├─sda5   8:5    0   300M  0 part /boot
└─sda6   8:6    0   4.1G  0 part [SWAP]

and after running grup-update

Generating grub configuration file ...
Found theme: /usr/share/grub/themes/manjaro/theme.txt
Found linux image: /boot/vmlinuz-5.9-x86_64
Found initrd image: /boot/intel-ucode.img /boot/initramfs-5.9-x86_64.img
Found initrd fallback image: /boot/initramfs-5.9-x86_64-fallback.img
Found Windows 10 on /dev/sda1
Found memtest86+ image: /boot/memtest86+/memtest.bin

please can someone help i have an urgent work to do in windows and i cant boot to it :frowning:

Hello :slightly_smiling_face:!
First of all, we need to know if you are using an UEFI or MBR partition scheme. Is your parition table “msdos” or “gpt”?
Additionally, could you post the output of

sudo fdisk -l


inxi -Fxzc0 

That would help us diagnose your system.
If you have UEFI, there’s a good chance your bootloader can be repaired, we just got to make sure you are running UEFI first as the instructions for MBR/BIOS are very different.

1 Like

hello thanks for reply

its gpt

Disk /dev/sda: 447.13 GiB, 480103981056 bytes, 937703088 sectors
Disk model: KINGSTON SA400S3
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: gpt
Disk identifier: 5E32CB90-7993-4CD0-BCCD-BD31C4F513C4

Device         Start       End   Sectors  Size Type
/dev/sda1       2048 181394035 181391988 86.5G Microsoft basic data
/dev/sda2  181395456 181616639    221184  108M Microsoft basic data
/dev/sda3  181617496 854740991 673123496  321G Microsoft basic data
/dev/sda4  854740992 928468991  73728000 35.2G Linux filesystem
/dev/sda5  928468992 929083391    614400  300M Microsoft basic data
/dev/sda6  929083392 929099775     16384    8M Linux filesystem
/dev/sda7  929099776 937703054   8603279  4.1G Linux swap

Disk /dev/sdb: 7.45 GiB, 8002732032 bytes, 15630336 sectors
Disk model: Cruzer Blade    
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: gpt
Disk identifier: AB520E22-1824-42C8-9C25-28CD3980BE3B

Device     Start      End  Sectors  Size Type
/dev/sdb1   2048 15630302 15628255  7.5G Microsoft basic data
System:    Kernel: 5.9.11-3-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 Desktop: KDE Plasma 5.20.4 Distro: Manjaro Linux 
Machine:   Type: Desktop System: Gigabyte product: H97-D3H v: N/A serial: <filter> 
           Mobo: Gigabyte model: H97-D3H-CF v: x.x serial: <filter> BIOS: American Megatrends v: F6 date: 04/21/2015 
CPU:       Info: Dual Core model: Intel Core i3-4160 bits: 64 type: MT MCP arch: Haswell rev: 3 L2 cache: 3072 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 28746 
           Speed: 3021 MHz min/max: 800/3600 MHz Core speeds (MHz): 1: 2993 2: 2993 3: 2993 4: 2993 
Graphics:  Device-1: Intel 4th Generation Core Processor Family Integrated Graphics vendor: Gigabyte driver: i915 v: kernel 
           bus ID: 00:02.0 
           Device-2: NVIDIA TU116 [GeForce GTX 1660] vendor: ZOTAC driver: nouveau v: kernel bus ID: 01:00.0 
           Display: x11 server: X.Org 1.20.10 driver: intel,modesetting,nouveau resolution: 1920x1080~60Hz 
           OpenGL: renderer: NV168 v: 4.3 Mesa 20.2.3 direct render: Yes 
Audio:     Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor HD Audio driver: snd_hda_intel v: kernel bus ID: 00:03.0 
           Device-2: Intel 9 Series Family HD Audio vendor: Gigabyte driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
           Device-3: NVIDIA TU116 High Definition Audio vendor: ZOTAC driver: snd_hda_intel v: kernel bus ID: 01:00.1 
           Sound Server: ALSA v: k5.9.11-3-MANJARO 
Network:   Device-1: Intel Ethernet I217-V vendor: Gigabyte driver: e1000e v: kernel port: f080 bus ID: 00:19.0 
           IF: eno1 state: up speed: 100 Mbps duplex: full mac: <filter> 
Drives:    Local Storage: total: 454.58 GiB used: 9.12 GiB (2.0%) 
           ID-1: /dev/sda vendor: Kingston model: SA400S37480G size: 447.13 GiB 
           ID-2: /dev/sdb type: USB vendor: SanDisk model: Cruzer Blade size: 7.45 GiB 
Partition: ID-1: / size: 34.35 GiB used: 9.06 GiB (26.4%) fs: ext4 dev: /dev/sda4 
           ID-2: /boot size: 299.4 MiB used: 62.8 MiB (21.0%) fs: vfat dev: /dev/sda5 
Swap:      ID-1: swap-1 type: partition size: 4.10 GiB used: 0 KiB (0.0%) dev: /dev/sda7 
Sensors:   System Temperatures: cpu: 29.8 C mobo: 27.8 C gpu: nouveau temp: 23.0 C 
           Fan Speeds (RPM): N/A gpu: nouveau fan: 1126 
Info:      Processes: 203 Uptime: 3m Memory: 7.64 GiB used: 1.42 GiB (18.6%) Init: systemd Compilers: gcc: 10.2.0 
           Packages: 1229 Shell: Bash v: 5.0.18 inxi: 3.1.08 

i hope this help :smiley:

So, my theory is that when you removed the Kali Linux grub, you accidentally also removed parts of the Windows Boot Manager. Without it, Windows 10 cannot be booted in UEFI mode, even if it is detected by GRUB.

In order to fix the Windows Boot Manager, you will need a number of things:

  1. A working Windows 10 installation media
  2. A new empty EFI system partition on your drive
  3. A bit of luck
  4. A lot of Patience

Before beginning this procedure, you NEED to back up all of your important data to a removable / remote location that can be isolated from your system. What we will try to do is potentially dangerous and you shoud make sure your data is safe BEFORE trying this!
You also have to understand that you are doing this at your own risk.

You may also want to consider a clean re-installation of Windows 10 for a less convoluted experience.

Creation of Installation Media (Click to expand)

============ Creation of Installation Media ============

First of all, if you don’t have a working Windows 10 installation media yet, you need to create one.
Skip straight to “Creating an EFI system partition” if you already have one.
You may download a Windows 10 ISO image free of charge from Microsoft’s website:

Once you obtained the Windows 10 .iso file, you need to burn it to a dual-layered DVD or a USB-Stick with at least 8GB capacity.
A common tool for flashing images onto USB-Sticks is WoeUSB.
You can install WoeUSB with the following command:

sudo pacman -Syu woeusb

Once WoeUSB is installed, plug in a USB-Stick into your PC that does not contain ANY important data (ALL DATA on the USB-Stick will be DELETED!) and open WoeUSB from the start menu.
Now, select you downloaded Windows 10 .iso file, set “File system” to NTFS, select your USB-Stick and press ‘Install’.
You might have to increase the window size to see the list for available devices.

After you click install, enter your password in the password prompt and wait for the process to complete.
Your USB-Stick should now be able to be booted and serve as a Windows 10 installation media.

Creating an EFI system partition (Click to expand)

============ Creating an EFI system partition ============

Once you have a Windows 10 installation medium, there’s one thing left to do before we boot it.
During the process of removing the Kali Linux grub, your EFI System partition has gone missing.
Manjaro has created a new one, but its layout is incompatible with Windows 10, you need to create an additional and new EFI system partition.

Now comes the most difficult part.

A last reminder: Back up your data! What we are about to do is VERY dangerous!

The easiest way to do this is to use GParted.
In case it isn’t installed on your system, you can install it with the following command:

sudo pacman -Syu gparted

Now, we somehow need to create a new FAT32 partition on your disk, preferably around 500MB in size.
Firstly, open gparted from the start menu and enter you password, then gparted should be able to start.
Make sure to select your main disk.
Since you have no unallocated space on your disk I would suggest shrinking another partition to make room for the EFI System partition.
To do this, right click the partition that you want to shrink (Warning: This is only possible with partitions that aren’t used by Linux, for example your Windows Partition) and select “Change Size”:

In the dialog, reduce the “New Size” parameter until the “Following free space” parameter is around 500:

Afterwards, press “Change Size” to shrink the partition.
Once done, you have to press the green check to apply changes:

Once this is done, you should have around 500MB of unallocated space one your drive.
Right click on the unallocated space, Select “New” and create a FAT32 partition:

Once you clicked “Add”, you need to once again apply all changes.
When the partition is created, we still need to mark it as a EFI System Partition.
To do this, right click on the new FAT32 partition and select “Change Labels”:

Finally, you need to set a checkmark on “boot” and “esp”:


After all of this completed, we are done inside Manjaro itself.
You will now have to boot your Windows 10 installation Media.

Repairing the Windows Boot Manager (Click to expand)

============ Repairing the Windows Boot Manager ============

Since we now have a new empty EFI system partition, all that’s left to do is to tell Windows’ bcdboot utility to copy over the lost parts of the Windows Boot Manager to this new partition.

First of all, you need to boot up your Windows 10 installation media in UEFI mode.
After the start screen appears, don’t click “Install Now”.
Instead, you should click on “Repair You Computer”:

Next, click on “Troubleshoot” and then “Command prompt”.

Once the command prompt is open, you need to find the drive letter of your Windows installation.

Try switching drives with commands like C:, D: or E: and list their contents with dir.

Once you found the driver with your Windows Install (It contains folders like “Program Files” and “Windows”), remember its drive letter.

Next, we switch back to the live environment with the command X:

Once there, run the following command:

bcdboot <drive letter of your Windows 10 install>:\windows

If no errors are reported, you should be able to reboot, and a new entry called “Windows Boot Manager” should be visible in your UEFI that allows you to boot Windows 10.

I know this is painfully long, but its the only fix I know of. Sorry for the wrong system locale in the screenshot, but changing that is not a quick procedure in Linux :wink:.

If you experience any problems or need further assistance, feel free to reply.


Hi all,

I am new to this community and manjaro Linux. After installation, I am not able to boot my Windows. While, I shall take time to read above replies and solutions, I wanted to post the problem I am facing with Windows boot now.

can you boot Manjaro and do you have grub ,if not get by sudo pacman -Syu grub this will also upgarde your system ,so no other issue occur with grub

Sorry for the delay!!

Let me try what you suggest.

Yes, I am able to boot manjaro.

1 Like