Can't Boot Into USB Installer

Hello,
I’ve been trying to install Manjaro KDE on my old laptop (HP Pavilion DV6 6171TX) but for some reason is only displaying a black screen with a “GRUB” text on the top left corner when booted on a USB. I’ve seen a similar problem where you have to add ‘nomodeset’ to the kernel boot options but this one doesn’t even let me in GRUB and select my options so I suspect it’s the GRUB bootloader itself (even when holding down Shift key) and nothing else.

I suspected that the installer doesn’t support BIOS booting so I tested the installer on another machine and it still worked even when I selected the option of booting in BIOS. I don’t know what is happening here. Any solutions?

:+1: Welcome to Manjaro! :+1:

Have you:

  1. Verified the sha1 hash for your download? (currently 6e83f14bc247db7195a668ac377e5f5ab272ef66 for the latest KDE download)
  2. tried booting from a DVD?

as the HP Pavilion DV6 6171TX has as Video Graphics hardware an AMD Radeon HD 6770M, it should just work out of the box.

:sob:

How long have you waited? I’ve seen old computers taking a lot to boot, but they eventually do boot. Just let it be for 15 min. or something. If it boots, it’s possible that the grub menu presents a huge lag. Just be patient. After booting it will just just fine.

1 Like

I did download a new ISO and verified it with Hash It, and sure enough it is the correct one.
A DVD is not something I cannot find easily here haha, as I’m still illegal to go outside to the mall and buy one.

I have waited maybe 10 minutes before I stopped waiting. My laptop heats up very quickly in the process of booting (when pressing the power button, it will sometimes display a black screen first then boot after 10 minutes), and is the same way when waiting for a usb installer to run. So I’m not very good at letting my laptop melt itself haha, but I have tried pointing a lot of fans to it and wait for another 10 minutes, and hasn’t done anything yet.

Did you disable secure boot? Try that, if not, check if other linux isos boot so we can start ruling things out.

There’s no secure boot option in the BIOS. and elementary OS, Ubuntu, and Linux Mint’s installers all work with ‘nomodeset’ method otherwise they will just display a black screen. I can remove the nomodeset option tho after installing graphics drivers manually.

Hmm… weird. Is there a particular reason to you wanting to use Manjaro? If what you want is to have an arch base, but also be user friendly, you can try with Garuda Linux. Just don’t download the “Ultimate” packages… those are bloated as hell. Otherwise, I really don’t know how to debug this, sorry.

1 Like

Ok, you waited enough. Try an ISO with an older kernel. I suspect that for some reason the most recent kernels don’t work well with that laptop.

2 Likes