Can't boot into Manjaro after partition resize

I am dual booting Windows 11 and Manjaro on my machine. I decided that I needed some more space on my Manjaro partition, so I did something stupid, I tried to shrink my Windows partition and expand my Manjaro partition (to the left) with a Windows software. When the resizing was about to finish, Windows crashed with a BSOD. Then I couldn’t boot into Windows or Manjaro. Windows shows some error screen while Manjaro hangs on the boot screen.

I booted into a Manjaro live ISO to try to fix the problem. I think my Windows partition is completely corrupted. I tried to recover my Manjaro partition by following the Manjaro GRUB restore guide (sorry I can’t link here). I am able to chroot into my Manjaro partition and run grub-install. However when running grub-mkconfig -o /boot/grub/grub.cfg, this is the output:

[manjaro-gnome grub]# grub-mkconfig -o /boot/grub/grub.cfg
Generating grub configuration file ...
Found theme: /usr/share/grub/themes/manjaro/theme.txt
Found linux image: /boot/vmlinuz-5.15-x86_64
Found initrd image: /boot/intel-ucode.img /boot/initramfs-5.15-x86_64.img
Found initrd fallback image: /boot/initramfs-5.15-x86_64-fallback.img
Warning: os-prober will be executed to detect other bootable partitions.
Its output will be used to detect bootable binaries on them and create new boot entries.
grub-probe: error: cannot find a GRUB drive for /dev/sdb1.  Check your
grub-probe: error: cannot find a GRUB drive for /dev/sdb1.  Check your
Adding boot menu entry for UEFI Firmware Settings ...
Root filesystem isn't btrfs
If you think an error has occurred, please file a bug report at ""
Found memtest86+ image: /boot/memtest86+/memtest.bin
/usr/bin/grub-probe: warning: unknown device type nvme0n1.

I guess os-prober can’t find the Manjaro partition (nor Windows). I am completely lost at this point. I tried to compare UUIDs between lsblk -f and etc/fstab, however lsblk -f does not show any UUIDs for any partitions. This is what cat etc/fstab returns:

[manjaro-gnome /]# cat etc/fstab
# /etc/fstab: static file system information.
# Use 'blkid' to print the universally unique identifier for a device; this may
# be used with UUID= as a more robust way to name devices that works even if
# disks are added and removed. See fstab(5).
# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
UUID=58BB-1004                            /boot/efi      vfat    umask=0077 0 2
UUID=f4f24443-20c6-48aa-9fac-2593e23538a8 /              ext4    defaults,noatime 0 1
tmpfs                                     /tmp           tmpfs   defaults,noatime,mode=1777 0 0

Any help would be appreciated

Most likely you completely bricked both systems, so best advice is to start over from scratch…

I’d check the UUIDs and compare with the fstab in your Manjaro installation via chroot, this might have changed. Try adjusting accordingly. But I tend to agree with @TriMoon on this.

You should never use Windows utilities to mess around with non-Windows partitions as they aren’t written for this sort of thing. It’s possible (but maybe not recommended) to do it the other way round i.e. with KDE Partition Manager, GParted etc…

You’ve finally learned to never trust any Windows software/tool.

Did you backup before the corrupted resizing?

Sounds like you got your system mostly working.

Have you mounted your efi system partition (esp) when chrooting into your system?
It’s the partition the grub boot loader lives on.
It should be a small fat32 partition of 100MB to 1GB likely the first entry and it probably needs to be mounted at /boot/efi.

Also check your partition table with gdisk (p to print it and v to check validity) and your file systems with fsck.

1 Like