Can't boot into Manjaro after fresh installation

Hello good people, I ran into a problem.
I have done a fresh installation of Manjaro Plasma with dual-boot with Windows 10 on UEFI mode.

Installation steps were,

  1. Burn ISO using Rufus
  2. Boot into LiveUSB Manjaro on UEFI
  3. Create dev/sda6 fat32 /boot/efi partition and flag it as boot
  4. Create dev/sda7 ext4 / partition
  5. Installation done and Reboot

But after installation I can’t see Manjaro on boot entry, I checked with efibootmgr (on live USB); it shows a Manjaro entry that is hidden (on boot menu(F12)). I installed Manjaro before with tsame steps, but didn’t face any problem.

Later I did grub-menu-style=menu from live usb and tried sudo update-grub. But update-grub didn’t work due to this “usr/bin/grub-probe: error: failed to get canonical path of ‘overlay’.” error.

Newbie here, don’t know to fix this.

Anyone? :roll_eyes:

Hi @shmVirus, and welcome!

I’m by no means an expert, so not sure if this’ll even work.

That said, I suggest trying to update grub from a chroot environment.

  1. Boot into the Live ISO image.

  2. When it’s ready and booted, open a terminal.

  3. In the terminal, enter the command manjaro-chroot -a

  4. If all is successful, you are now in a live root session on your installation. So be very careful when proceding.

  5. Since you are logged in as the root user, run

$ update-grub
  1. When finished, exit and reboot.

Once again, I’m not an expert, so this might not work. It is, however, what I recommend.

this solved the problem @shmVirus ?

I know its not recommended using rufus to create a live usb as it can cause issues. Etcher seems to be recommended for manjaro. Hope that helps

to create live usb on gnome with the disks application use the restore image function to create a perfect live usb, I recommend using that way