Can't boot from USB

I have a bootable USB with the cinnamon minimal install, and when I boot from it, after choosing to boot with either proprietary or not drivers, it says :

Mount: /run/miso/sfs/rootfs: wrong fs type, bad option, bad superblock on /dev/loop3, missing code page or helper program, or other error.
ERROR: Failed to mount ‘/dev/loop3’

What should I do ?
I have checked the sha512 and it is not corrupted.

You mean ‘cinnamon minimal iso’, right?
The error looks like something’s wrong with either the drive or the way it was written to it.
Make sure you’re using an approved app to create the boot drive (ventoy?) and maybe try a different drive if available.

Thank you for your help.
Yes I’m talking about this one.
I’m using dd. I don’t have any other USB key right now. Are there USB keys that don’t work ? If I buy a new one, how do I know if it will work ?

dd will appear to finish the writing task quite quickly
make sure you issue
and wait for it to come back to a prompt
before you disconnect the drive you have written to

or use Ventoy - much easier and more versatile - you can still use the drive as storage and put as many iso’s on as will fit …

1 Like

or you could go into windows and burn it via Rufus. balena etcher is also a good option but it didn’t work for me on xfce

… just adding that Ventoy is available for Windows too

It makes the thumb drive a bootable device,
then you just simply copy whatever ISO to it and can select to boot from it - and keep using the thumb drive as normal storage as well.

i am aware of ventoy. but for small drives like 8 gigs or 6 gigs (i actually have a couple) ventoy doesnt work as good as others

Did you check the ISO only, or the USB stick also?

Plus maybe check your BIOS settings with respect to USB-drives, on some BIOS’es you can set it to emulate a HD,Floppy,CDROM etc, best is to set it to auto.

I wouldn’t know.
I only have one thumb drive - have had it for years.
It was rather large at the time and still serves me well.
4 GB - Ventoy made it bootable … never had a problem with it
nor with using it before Ventoy was a thing - dd was what I used to use.
Also cp (to the device, not to the partition …) works, and cat as well. Easier syntax.
Using dd is just a habit and is the prime example in most guides - cp works just the same … it’s just rarely mentioned

1 Like

No one can know that.
Did you know that “NEW” is just an acronym for “Never Ever Worked”?
Only once you try, once you use it, will you know. :grin:
It will very likely work.
But so will what you currently have.

1 Like

Ok, Ventoy worked thx everyone.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.