Can't Boot from Live USB

I have been struggling for days now trying to get installed. I have tried all the advice I can find and searched through the forums and not found anything that helped me.
I am trying to install Manjaro but I want to install other flavors as well. The bootloader works fine, but if I choose proprietary drivers the screen blanks and reboots several minutes later. If I use open-source drivers the system hangs:

I tried other installers with similar results:

  • Manjaro KDE 23.1.3-240113
  • Kali Linux 2023.4 AMD64
  • Debian 12.5.0 AMD64 Netinstaller
  • FossaPup64 9.5
  • KaOS 2024.01 x86_64
  • Kubuntu 22.04.4
  • LinuxMint 21.3 Mate 64
  • MX 23.2 AHS
  • MX KDE 23.2
  • Clonezilla Live 3.1.2-9 AMD64
  • openSUSE Tumbleweed x86_64
  • Rescuezilla 2.4.2 64bit Jammy
  • System Rescue 11.00 AMD64

Windows 10ent is installed on SSD but I’m not trying to install there. Windows works fine and is not throwing an extraordianary amount of errors. (i.e. I’m not seeing any evidence that the CPU is damaged)

I have tried:

  • disabled Secureboot

  • disabled fastboot

  • Verified hashes on all iso before using

  • Updated to the latest BIOS version (38g)

  • Have found references to people using the same motherboard and processor (though not together) and running Manjaro and other flavors of linux successfully.

  • Set the BIOS to UEFI only/CSM disabled

  • Set the BIOS to UEFI CSM enabled

    • mass storage UEFI only
    • mass storage legacy only
    • mass storage disabled
  • Swapped the video card for an older GTX card

  • tested the ram modules

  • burn the iso to usb with Rufus (UEFI/GPT)

  • burn the iso to usb with unetbootin (UEFI/GPT)

  • used Ventoy to load all the iso to the same usb stick and run from there (UEFI/GPT NTFS)

  • Set CSM to enabled and burned the USB as MBR

  • Tried every usb port (USB3 and USB2)

  • unplugged all other drives

  • I am currently reformatting the usb to mbr to try all the flavors again.

  • FreeBSD is the only system that made it through the installer. No linux.

I have that feeling like I’m missing something really obvious, but no clue what.

System Spec:

  • Ryzen 7 3700 CPU
  • Aorus X570 Elite Wifi MoBo
  • NVidia GTX 1660 Ti 6GB GPU
  • 2x16GB RAM GSkill Ripjaws in slots 2A and 2B

Additional screenshots (This is from KaOS if I remember right, lost track)

and from openSUSE:

Hello @WhiteRaven_Couatl :wink:

Looks to me like you’re having trouble processing data. On the one hand you have I/O errors related to your storage media (flash drive, NVME), but also one time a MCE error. MCE errors can be very random and unpredictable. Basically a RAM module is faulty: should be bank 5, presumably the fourth memory module?

In any case, I’m assuming this is a faulty RAM module. And if you now say: “But the error doesn’t happen on Windows!” Linux and Windows use RAM differently. With Windows it simply takes longer and depends on usage, Linux has a global cache and can quickly trigger bad areas.

Thanks for the advice. I previously removed the RAM module in slot 2B and tested the one in slot 2A with memtest with no errors after the first pass. I’ll try swapping them around some more tomorrow, (I’m out of time to work on it today). I’ll see if I can dig up some old modules to try, not sure if I have any that are the right standard. I’ll let you know how it turns out.