Can't boot from flash drive or dvd

so i need to uninstall manjaro and go back to windows but it didn’t allow me to boot from flash drive or dvd even tho i placed them first on the priority list.
any help?

It’s probably the way you created the Windows boot medium.
I’d suggest to install ventoy,
use it to prepare an usb stick
and then, when it’s finished
just copy the windows iso to that usb stick

There is at least one other way to create a bootable windows medium
I think it is called woeusb or something like that.
You can try both - or search for how to create a bootable windows medium on linux.
I’m sure you’ll find good references.

i used balena etcher and tried doing it from the terminal, neither worked,
i also had a windows 7 cd around and it didn’t boot either.
no matter what i choose in the boot menu it always boots manjaro and uefi mode refuse to boot anything.(i can post photos if needed)

i’ll try what u suggested, if it doesn’t work i guess i’ll just go to a pc shop, although i don’t think it’ll be easy to find someone familiar with linux where i live.

You cannot boot another system from terminal or from within linux.
That is the job of the BIOS.
You have to use that to boot another system.

Shutdown, power off, power on, select medium to boot from.
any installed linux or windows isn’t involved here
… maybe I misunderstood something here …

When your PC or laptop is booting
it does not matter what system is on it right now.

Not for the ability to detect a medium it is supposed to be booting from.

This isn’t a Manjaro issue.

It’s an issue with either your medium
or your PC’s Bios/UEFI
not being able to detect and use that medium to boot from.

If your Windows CD
specially made exactly for this purpose
could not be booted
(and assuming it is in good shape)
then it is your hardware or BIOS that is the problem.

Just as you should be able to boot a Manjaro installation medium
(can you? - you could in the past, since you did at some point install Manjaro)
you should be able to boot a different installation medium (Windows - or any other OS).

If one works, but not the other
it is the way you created it that is the problem.

You could cross-check on a different PC whether your windows medium is actually working.

no linux knowledge is required
to boot any installation image
linux or not

this is not a linux issue

I don’t personally know that program.
I only ever used dd to create bootable images
(and ventoy, recently - where this is not required
you just copy the ISO …)

… since you mentioned to have a Windows install CD:
you have to use an ISO file (a disk image)
not! the contents of that Windows CD

Do you have an Windows ISO file?

First, yes you did misunderstand, probably bc of my bad explanation and me assuming manjaro is the problem as my bios/uefi was warking just fine when i installed it(and no, even a manjaro installation medium wouldn’t boot now,thanks for pointing that out).

The thing is no matter what i select to boot from in the boot menu it always boots from the hard drive and thus manjaro.

The flash drive has an iso file for windows 10 which i downloaded from the official website, the cd has windows 7 and i wasn’t the one who made it.

Someone suggested i use a windows pre-installation environment, if it doesn’t work, i guess i’ll look into a way to troubleshoot or update my bios/uefi.

If nothing works i guess i’ll just use a vm.

of course I have no idea what might have happened
in between the time when you used such medium to install Manjaro
where it worked
and now, where the same thing doesn’t want to boot.

If that doesn’t work, it’s not surprising that other install media also don’t work.

As for the possible reason:
I have no idea how it could have changed from working to not working - aside from a hardware issue
which is also unlikely because you can’t boot off of CD-ROM either, as well as off of USB.

Like you - I’m at a loss.

yeah, well thank you for your time anyway.