Can't boot anymore after dd from SD card to eMMC

Hi there,

Today I decided to reinstall Manjaro Plasma on my RockPro64’s eMMC (because I messed up too much with the existing install).

So I created a bootable SD card from my Pinebook Pro with the command sudo dd if=./Manjaro-ARM-kde-plasma-rockpro64-21.12.img | sudo dd of=/dev/mmcblk1 status=progress (mmcblk1 was the SD card)

Then I inserted this SD card in my RockPro64 and booted from it.
I copied the same Manjaro-ARM-kde-plasma-rockpro64-21.12.img on the SD card using a USB Key and then I flashed to eMMC with the same command

sudo dd if=./Manjaro-ARM-kde-plasma-rockpro64-21.12.img | sudo dd of=/dev/mmcblk1 status=progress

(don’t remember if the eMMC was mmcblk1 or mmcblk2 but I know I did it right)

After that, another sudo fdisk -l showed me a warning GPT PMBR Size Mismatch will be corrected by w(rite) at reboot (or something like that) for the SD card !
I didn’t really care as I thought I didn’t need the SD card anymore. I was thinking to just turn off the RockPro64, remove the SD card and turn it on to boot from the eMMC but that didn’t work as expected…

After that I couldn’t boot anymore neither from the eMMC nor from the SD card. Nothing happens.

I tried flashing the image again on my SD card (which is a brand new card actually) but didn’t work. Then I tried flashing it on another brand new card but the same.

I really don’t know what to do anymore.
I’ve seen on this thread that I should maybe fix the uboot but I didn’t really understand the answer.
If I flash a brand new SD card am I not supposed to have a brand new working uboot already?

What can I do now that I can’t boot at all my RockPro64?

(I really want to avoid opening the RockPro64 to flash the eMMC with an eMMC to USB adapter. I remember it was REALLY annoying closing the RockPro64 aluminum case)

Thanks for your answer

1 Like

We are aware of issues when using u-boot 2021.10 from eMMC. The fixes for the uboot packages are not ready yet.

So what’s the solution for me now?
Will the boot work if I flash the SD card with an older version on Manjaro Plasma?

Same here, is there any workaround, even if temporary?

EDIT: I was able to flash uboot on SPI and now my system boots. However I get a “Give root password for maintenance”. If I enter it, I get no instruction on what to do but systemd is in maintenance mode so there is not much I can do… Nothing works. What should I do to restore my system?

I am working on updating our rk3399 uboot packages with a patch that should fix this issue.


I was not able to restore from eMMC corruption, and I didn’t bother to dig deeper.

I had to:

  • flash uboot into SPI
  • flash latest majaro image in an unused SD Card
  • Mount eMMC inside latest manjaro
  • backup relevanot configuration
  • Flash eMMC with latest manjaro
  • restore config backup

Now my system is back again, but it was a lot of work.
Hope this does not happen again.
Also, I don’t understand how an uboot update can possibly corrupt my eMMC? Maybe this was just an unfortunate coincidence?

1 Like