Can't boot after recent update, drivers fail to update from terminal

After the recent update to kernel 5.10, my boot freezes at the motherboard splash screen. I assume this has to do with my having an Nvidia card (see mhwd output below), so I attempted to uninstall and then reinstall my video drivers. Both sudo mhwd -a pci nonfree 0300 and sudo mhwd -a pci free 0300 gave the same error:

failed to update multilib (invalid url for server)
failed to synchronize all databases
pacman failed!
script failed!

Attempting to run sudo pacman -Syu gives me a similar error.

mhwd output:

    video-nvidia
    video-nvidia-390xx
    video-linux
    video-modesetting
    video-vesa

run Pacman-mirrors - Manjaro

Runnning sudo pacman-mirrors --fasttrack && sudo pacman -Syyu gives me the failed to update multilib (invalid url for server) and failed to synchronize all databases errors.

I’m wondering if this might be an issue with my Internet connection (although I have no reason to believe I’m not connected). How would I test my Internet connection, and/or connect to a Wi-Fi network using only the terminal?

Try to reset your mirrors and then update by

sudo pacman-mirrors --country all --api --protocols all --set-branch stable && sudo pacman -Syyu

nmtui to connect

Running that command gives me the failed to update multilib (invalid url for server) and failed to synchronize all databases errors again.

@asorel is your internet connection really OK? Are you sitting behind a proxy or third-party firewall?

I have neither outside proxies nor firewalls in place on my home network, no. I didn’t get any error messages when I manually connected to my network using ntmui, and I have no issue accessing the Internet from other devices connected to the same network, nor does this machine have a history of connectivity problems after an update, so I have no immediate reason to assume Internet trouble. Are there steps I can take to ascertain that whether my machine is properly connected?

Please post:

systemctl status systemd-resolved

If it’s enabled, try

systemctl disable --now systemd-resolved

Output was:

systemd-resolved.service - Network Name Resolution
Loaded: loaded (/usr/lib/systemd/systemd-resolved.service; disabled; vendor preset; enabled)
Active: inactive (dead)

Seems like it’s disabled already. What would my next step be after this?

What’s the output of:

cat /etc/pacman.conf
cat /etc/pacman.d/mirrorlist

See attached images

And for the second command:

Looks fine to me.
Is your internet really ok, can you fetch this file?

curl https://manjaro.moson.eu/state

Hmm, I got a “Could not resolve host” error. I guess there is some issue with the Internet.

So yeah, DNS is not working.

Check if you have a connection at least.

ip link
ping 8.8.8.8

Hit CTRL-C to cancel ping after a couple of seconds.

It appears that I got a positive response from both commands:

please run nmcli

Thank you for taking the time to walk me through this, I appreciate it. Seems like my wifi radio is disconnected, what’s next?

Strange. I’m wondering why you could ping then.

Try using nmtui to connect.