Can't boot after installation


I just installed a Manjaro in my laptop and dual boot with windows 7 ,but after i reboot my laptop i can’t access any operating system . That said “Missing operating system” . Im installing the Manjaro without using any bootable device but i’m using a unetbootin and i put that bootloader file in the “c:/” drive . And now what can i solve this ?

Welcome to the forum! :slight_smile:

I’m sorry, but to the best of my knowledge, that kind of installation is not supported. If you don’t want to dedicate any disk space to Manjaro, then your best bet is to install it in a virtual machine. :man_shrugging:

Thank you!!

I already make a one partition separated and im install the manjaro in it. Before i reboot my laptop i check that partition has installed the manjaro. The problem now is i can’t access the other operating system or i must installed a GRUB?

Yes, GNU/Linux needs a boot loader, and the default boot loader for Manjaro is GRUB. However, a lot depends on what kind of partition table you have, and whether your computer boots in native UEFI mode or in legacy BIOS compatibility (CSM) mode.

If the machine boots in native UEFI mode, then the only type of partition table Manjaro supports is a GPT (GUID Partition Table). And in that case, you need a special partition of 512 MiB in size, formatted as FAT32 and marked with the boot or esp flag in the partition table. This partition must be mounted at /boot/efi.

If on the other hand the machine boots in legacy BIOS compatibility mode, then you can use either a GPT or a traditional MS-DOS MBR partition table.

  • In case of the latter, you don’t need to do anything special, but then when the installer asks you where to install the boot loader, you must tell it to install in /dev/sda, or whatever the designation for the boot drive in your system is.

  • In case of a GPT partition table in combination with a legacy BIOS compatibility boot, you need to create a special partition of type bios_grub, unformatted, about 2 MiB in size, and marked with the bootflag.

Also important is that if you have two operating systems on the same drive, then they must either both boot in native UEFI mode or both in legacy BIOS compatibility mode. You cannot have one operating system installed in native UEFI mode and another in legacy BIOS mode, because then the boot loader won’t detect both systems.

Both of operating system is use legacy ,and i install the manjaro with MBR mode ,the problem is i can’t acces the bios setup . What can i do next ? ,can i boot it with flashdrive and installed again or remove the Manjaro from my laptop ? or i can change several settings?, i never knew installing linux is very difficult than windows.

Yes, boot from the installer USB in live mode, open up a terminal and issue the following commands… :arrow_down:

sudo su -
manjaro-chroot -a

Then issue the following command… :arrow_down:

sudo nano /etc/default/grub

Look for the lines reading… :arrow_down:


… and… :arrow_down:


… and.change them into… :arrow_down:


… and… :arrow_down:


Save the file with Ctrl+O followed by Enter, and exit the editor with Ctrl+X. Then, enter the following two commands at the prompt… :arrow_down:

grub-install --recheck --no-rs-codes --modules="part_msdos part_gpt" /dev/sda

If your drive is something other than /dev/sda, then use that in the above command.

When finished, exit the chroot with Ctrl+D and safely reboot your computer.