Can't adjust brightness on my Legion 5i Pro

Hello !

I recently bought a Lenovo Legion 5i Pro, with an Intel I7-12700H and a Nvidia RTX 3070 Ti, and I tried to installed manjaro on it.
Everything worked fine during the installation, except if I tried to install it with the proprietary nvidia drivers. So I chose to install it with the free nouveau drivers, which seemed to work fine.
Until I booted on it, and saw that I can’t seem to be able to change the brightness. I tried everything I could find on the internet and this forum, adding handlers and event with acpid, but nothing seemed to work.
The only thing I was able to find that worked was to execute xrandr --output eDP-1 --brightness 0.5 to modify the brightness.

Could anyone help me please ?
Thanks in advance

Hi - did you see this one? Not sure what kernel you are using, since you have not provided any system information.

cheers Frank

Here is more informations from neofetch :

OS: Manjaro Linux x86_64 
Host: 82RF Legion 5 Pro 16IAH7H 
Kernel: 6.1.1-1-MANJARO 
Uptime: 26 mins 
Packages: 1446 (pacman) 
Shell: bash 5.1.16 
Resolution: 2560x1600 
DE: Plasma 5.26.4 
WM: KWin 
Theme: [Plasma], Breeze [GTK2/3] 
Icons: [Plasma], breeze [GTK2/3] 
Terminal: konsole 
CPU: 12th Gen Intel i7-12700H (20) @ 4.600GHz 
GPU: NVIDIA Geforce RTX 3070 Ti Laptop GPU 
Memory: 2791MiB / 31891MiB

please post the output of

ls /sys/class/backlight/

Isnt the Display Lighting controlled via keyboard combination? Or is that the problem, keyboard combo not functioning?

Here is the result :

> ls /sys/class/backlight/
acpi_video0  nv_backlight

yes sorry that’s what I meant, when I use fn+F5 or fn+F6, it has no effect, the slider is showing and the value is changing, but the value doesn’t reflect what happens since nothing happens

enable the aur in package-manager and install the


package. please report the result 8a reboot might be needed)

I’ve had the same issue on kernel 6.1. I had a brief email exchange with Hans, more info here:

Can you try to add video.register_backlight_delay=0 as a kernel parameter and see if that helps? If it helps its a known issue which got addressed with kernel version 6.1.5 or 6.1.6, I’m not really sure anymore.

I tried it, but didn’t work, even after a reboot, I still can’t adjust the brightness even though the slider works :frowning:

I also tried that, but didn’t work either. I edited /etc/default/grub to add this parameter, then did sudo update-grub && sudo mkinitcpio -P but it didn’t do anything after rebooting :frowning:

first things first, please post the output of

inxi --admin --verbosity=7 --filter --no-host --width

if you owe a laptop with nvidia (what i suggest) you have to use the propietary nvidia driver to control brightness (see the link below)

Here is the output of the command you suggested :

  Kernel: 6.1.1-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-6.1-x86_64
    root=UUID=4006f211-c2dd-4744-89f9-e42cd11929e2 rw quiet splash
  Desktop: KDE Plasma v: 5.26.4 tk: Qt v: 5.15.7 wm: kwin_x11 dm: SDDM
    Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: LENOVO product: 82RF v: Legion 5 Pro 16IAH7H
    serial: <filter> Chassis: type: 10 v: Legion 5 Pro 16IAH7H serial: <filter>
  Mobo: LENOVO model: LNVNB161216 v: NO DPK serial: <filter> UEFI: LENOVO
    v: J2CN48WW date: 11/16/2022
  ID-1: BAT0 charge: 59.7 Wh (73.0%) condition: 81.8/80.0 Wh (102.2%)
    volts: 16.1 min: 15.4 model: SMP L21M4PC2 type: Li-poly serial: <filter>
    status: discharging cycles: 55
  RAM: total: 31.14 GiB used: 2.84 GiB (9.1%)
  Array-1: capacity: 32 GiB slots: 2 EC: None max-module-size: 16 GiB
    note: est.
  Device-1: Controller0-ChannelA-DIMM0 type: DDR5 detail: synchronous
    size: 16 GiB speed: 4800 MT/s volts: curr: 1.1 width (bits): data: 64
    total: 64 manufacturer: SK Hynix part-no: HMCG78MEBSA092N serial: <filter>
  Device-2: Controller1-ChannelA-DIMM0 type: DDR5 detail: synchronous
    size: 16 GiB speed: 4800 MT/s volts: curr: 1.1 width (bits): data: 64
    total: 64 manufacturer: SK Hynix part-no: HMCG78MEBSA092N serial: <filter>
  Info: model: 12th Gen Intel Core i7-12700H socket: U3E1 bits: 64
    type: MST AMCP arch: Alder Lake gen: core 12 level: v3 note: check
    built: 2021+ process: Intel 7 (10nm ESF) family: 6 model-id: 0x9A (154)
    stepping: 3 microcode: 0x424
  Topology: cpus: 1x cores: 14 mt: 6 tpc: 2 st: 8 threads: 20 smt: enabled
    cache: L1: 1.2 MiB desc: d-8x32 KiB, 6x48 KiB; i-6x32 KiB, 8x64 KiB
    L2: 11.5 MiB desc: 6x1.2 MiB, 2x2 MiB L3: 24 MiB desc: 1x24 MiB
  Speed (MHz): avg: 2589 high: 2700 min/max: 400/4600:4700:3500
    base/boost: 2277/4700 scaling: driver: intel_pstate governor: powersave
    volts: 0.9 V ext-clock: 100 MHz cores: 1: 486 2: 2700 3: 2700 4: 2700
    5: 2700 6: 2700 7: 2700 8: 2700 9: 2700 10: 2700 11: 2700 12: 2700 13: 2700
    14: 2700 15: 2700 16: 2700 17: 2700 18: 2700 19: 2700 20: 2700
    bogomips: 107560
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat
    arch_capabilities arch_lbr arch_perfmon art avx avx2 avx_vnni bmi1 bmi2
    bts clflush clflushopt clwb cmov constant_tsc cpuid cpuid_fault cx16 cx8
    de ds_cpl dtes64 dtherm dts epb ept ept_ad erms est f16c flexpriority
    flush_l1d fma fpu fsgsbase fsrm fxsr gfni hfi ht hwp hwp_act_window
    hwp_epp hwp_notify hwp_pkg_req ibpb ibrs ibrs_enhanced ibt ida intel_pt
    invpcid invpcid_single lahf_lm lm mca mce md_clear mmx monitor movbe
    movdir64b movdiri msr mtrr nonstop_tsc nopl nx ospke pae pat pbe pcid
    pclmulqdq pdcm pdpe1gb pebs pge pku pln pni popcnt pse pse36 pts rdpid
    rdrand rdseed rdtscp rep_good sdbg sep serialize sha_ni smap smep smx
    split_lock_detect ss ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp syscall tm
    tm2 tpr_shadow tsc tsc_adjust tsc_deadline_timer tsc_known_freq umip vaes
    vme vmx vnmi vpclmulqdq vpid waitpkg x2apic xgetbv1 xsave xsavec xsaveopt
    xsaves xtopology xtpr
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB
    filling, PBRSB-eIBRS: SW sequence
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: NVIDIA GA104M [Geforce RTX 3070 Ti Laptop GPU] vendor: Lenovo
    driver: nouveau v: kernel non-free: 525.xx+ status: current (as of 2022-12)
    arch: Ampere code: GAxxx process: TSMC n7 (7nm) built: 2020-22 pcie: gen: 1
    speed: 2.5 GT/s lanes: 8 link-max: gen: 4 speed: 16 GT/s lanes: 16 ports:
    active: eDP-1 empty: DP-1,DP-2,HDMI-A-1 bus-ID: 01:00.0 chip-ID: 10de:24e0
    class-ID: 0300
  Display: x11 server: X.Org v: 21.1.6 with: Xwayland v: 22.1.7
    compositor: kwin_x11 driver: X: loaded: modesetting alternate: fbdev,vesa
    gpu: nouveau display-ID: :0 screens: 1
  Screen-1: 0 s-res: 2560x1600 s-dpi: 96 s-size: 677x423mm (26.65x16.65")
    s-diag: 798mm (31.43")
  Monitor-1: eDP-1 model-id: CSO 0x161a built: 2022 res: 2560x1600 dpi: 189
    gamma: 1.2 size: 344x215mm (13.54x8.46") diag: 406mm (16") ratio: 16:10
    modes: max: 2560x1600 min: 800x600
  API: OpenGL v: 4.5 Mesa 22.3.1 renderer: llvmpipe (LLVM 14.0.6 256 bits)
    direct render: Yes
  Device-1: Intel Alder Lake PCH-P High Definition Audio vendor: Lenovo
    driver: snd_hda_intel v: kernel alternate: snd_sof_pci_intel_tgl
    bus-ID: 00:1f.3 chip-ID: 8086:51c8 class-ID: 0403
  Device-2: NVIDIA GA104 High Definition Audio driver: snd_hda_intel
    v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 8 link-max: gen: 4
    speed: 16 GT/s lanes: 16 bus-ID: 01:00.1 chip-ID: 10de:228b class-ID: 0403
  Sound API: ALSA v: k6.1.1-1-MANJARO running: yes
  Sound Server-1: JACK v: 1.9.21 running: no
  Sound Server-2: PulseAudio v: 16.1 running: yes
  Sound Server-3: PipeWire v: 0.3.63 running: yes
  Device-1: Intel Alder Lake-P PCH CNVi WiFi driver: iwlwifi v: kernel
    bus-ID: 00:14.3 chip-ID: 8086:51f0 class-ID: 0280
  IF: wlp0s20f3 state: up mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: dynamic noprefixroute scope: global
  IP v6: <filter> type: noprefixroute scope: link
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Lenovo driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1
    port: 3000 bus-ID: 31:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp49s0 state: down mac: <filter>
  WAN IP: <filter>
  Device-1: Intel type: USB driver: btusb v: 0.8 bus-ID: 3-10:4
    chip-ID: 8087:0033 class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 3 state: down bt-service: enabled,running
    rfk-block: hardware: no software: yes address: see --recommends
  Message: No logical block device data found.
  Message: No RAID data found.
  Local Storage: total: 953.87 GiB used: 15.37 GiB (1.6%)
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: MZVL21T0HCLR-00BL2
    size: 953.87 GiB block-size: physical: 512 B logical: 512 B speed: 63.2 Gb/s
    lanes: 4 type: SSD serial: <filter> rev: CL1QGXA7 temp: 33.9 C scheme: GPT
  SMART: yes health: PASSED on: 64 hrs cycles: 346
    read-units: 4,988,134 [2.55 TB] written-units: 6,466,027 [3.31 TB]
  Message: No optical or floppy data found.
  ID-1: / raw-size: 58.59 GiB size: 57.37 GiB (97.92%) used: 12.01 GiB (20.9%)
    fs: ext4 block-size: 4096 B dev: /dev/nvme0n1p4 maj-min: 259:4 label: N/A
    uuid: 4006f211-c2dd-4744-89f9-e42cd11929e2
  ID-2: /boot/efi raw-size: 908.1 MiB size: 906.3 MiB (99.80%)
    used: 316 KiB (0.0%) fs: vfat block-size: 512 B dev: /dev/nvme0n1p7
    maj-min: 259:7 label: N/A uuid: 63F7-EBDE
  ID-3: /home raw-size: 57.71 GiB size: 56.5 GiB (97.91%)
    used: 3.36 GiB (5.9%) fs: ext4 block-size: 4096 B dev: /dev/nvme0n1p6
    maj-min: 259:6 label: N/A uuid: 7deade99-ad05-4819-b8a3-d7df68ab83b0
  Alert: No swap data was found.
  ID-1: /dev/nvme0n1p1 maj-min: 259:1 size: 100 MiB fs: vfat label: N/A
    uuid: 3CDB-8A53
  ID-2: /dev/nvme0n1p2 maj-min: 259:2 size: 16 MiB fs: N/A label: N/A
    uuid: N/A
  ID-3: /dev/nvme0n1p3 maj-min: 259:3 size: 835.99 GiB fs: ntfs label: N/A
    uuid: 9C1CDC581CDC2ED0
  ID-4: /dev/nvme0n1p5 maj-min: 259:5 size: 590 MiB fs: ntfs label: N/A
    uuid: 723044EF3044BBBB
  Hub-1: 1-0:1 info: Hi-speed hub with single TT ports: 1 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Hub-2: 2-0:1 info: Super-speed hub ports: 1 rev: 3.1 speed: 20 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  Hub-3: 3-0:1 info: Hi-speed hub with single TT ports: 12 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Hub-4: 3-2:2 info: Genesys Logic Hub ports: 2 rev: 2.1 speed: 480 Mb/s
    chip-ID: 05e3:0610 class-ID: 0900
  Device-1: 3-5:3 info: Integrated Express ITE Device(8910) type: Keyboard
    driver: hid-generic,usbhid interfaces: 1 rev: 2.0 speed: 12 Mb/s power: 100mA
    chip-ID: 048d:c102 class-ID: 0301
  Device-2: 3-10:4 info: Intel type: Bluetooth driver: btusb interfaces: 2
    rev: 2.0 speed: 12 Mb/s power: 100mA chip-ID: 8087:0033 class-ID: e001
  Hub-5: 4-0:1 info: Super-speed hub ports: 4 rev: 3.1 speed: 10 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  Hub-6: 4-3:2 info: Genesys Logic GL3523 Hub ports: 2 rev: 3.2 speed: 5 Gb/s
    chip-ID: 05e3:0620 class-ID: 0900
  System Temperatures: cpu: 34.0 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 329 Uptime: 6m wakeups: 10888 Init: systemd v: 252
  default: graphical tool: systemctl Compilers: gcc: 12.2.0 clang: 14.0.6
  Packages: pm: pacman pkgs: 1459 libs: 322 tools: pamac pm: flatpak pkgs: 0
  Shell: Zsh (sudo) v: 5.9 default: Bash v: 5.1.16 running-in: konsole
  inxi: 3.3.24

And yes I do have an nvidia card but whenever I use the nvidia driver, the system doesn’t boot anymore

please use the search function, install optimus-manager and use your nvidia-gpu. the nouveau driver that’s installed won’t work proper.


I also have Lenovo 5i pro with cpu - 12900H and gpu - RTX 3070Ti.
So I use only the dGPU you can change that in BIOS.
Brightness works in all modes hybrid and on dGPU only.

Uninstall the free drivers and install proprietary drivers. Do not reboot !!!
PRIME - ArchWiki this is the nvidia recommended way.
You can find tutorials online how to do this. Its not difficult.
Once when you install the prop. driver open /etc/default/grub with your favorite editor and edit this line

In terminal sudo update-grub

Reboot, if done correctly it should work. It works for me.

Again open /etc/default/grub and in GRUB_CMDLINE_LINUX_DEFAULT="..." add acpi_backlight=video if in hybrid mode!!
If on dGPU only add acpi_backlight=none

Don’t forget to sudo update-grub

This works for me in both modes. I use only dGPU mode because I couldn’t find a way to set the screen to 165Hz.

How to set you favorite editor to do this :slight_smile:
Open terminal and …

$ export $EDITOR="your favorite editor" 
$ echo $EDITOR                 --> to check that the editor is properly set
$ sudoedit /etc/default/grub   --> it will prompt you for your password write it and hit enter

Thanks a lot for the detailed explanation, I did exactly that until now, except I had always missed the part where I need to add ibt=off to my kernel option.
It now works fine, with only the nvidia driver, only using my dGPU.
But I didn’t add acpi_backlight=none and it seems to work fine. The only problem I still have is that 10% of brightness seems to be equal to 100%, and then 5% is about 70/80% and 0% is like 5%.
And I just change the brightness a lot between those values and it disabled my keyboard, I had to reboot twice to make it work again.
Do you know if it’s related?

I also can’t seem to be able to log in on sddm while wayland is selected, it only goes back again to the login screen at boot. It only works with X11

With dGPU mode you must set acpi_backlight=none, because if not set the kernel creates dir and file in /sys/class/backlight/ acpi_video0 is the dir, so now the control is mixed and for me it didn’t work with the keyboard buttons Fn + F5 or F6.

Its the same for me. I guess its driver issue. Also it doesn’t remeber the value for me because I am on twm, so I need to tweak it on each boot, but it doesn’t bother me that much.
Go upwards from 10% and you will see the changes and set it accordingly.

I didn’t have these problems. But pls add this acpi_backlight=none to grub and see if you have any problems regarding keyboard freeze.

I don’t have wayland installed so I don’t know, about it.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.