Can't add usershare using nautilus

When I try to add usersahre using nautilus-share pulgin I get the following error
'net usershare' returned error 255: net usershare add: cannot convert name "Everyone" to a SID. The transport connection is now disconnected..
my smbd.conf content :

   workgroup = WORKGROUP
   dns proxy = no
   log file = /var/log/samba/%m.log
   max log size = 1000
   server min protocol = SMB2_02
   server max protocol = SMB3
   server role = standalone server
   passdb backend = tdbsam
   obey pam restrictions = yes
   unix password sync = yes
   passwd program = /usr/bin/passwd %u
   passwd chat = *New*UNIX*password* %n\n *ReType*new*UNIX*password* %n\n *passwd:*all*authentication*tokens*updated*successfully*
   pam password change = yes
   map to guest = Bad Password
   usershare allow guests = yes
   name resolve order = lmhosts bcast host wins
   security = user
   guest account = guest
   guest ok = yes
   usershare path = /var/lib/samba/usershares
   usershare max shares = 100
   usershare owner only = false
   force create mode = 0070
   force directory mode = 0070
   load printers = no
   printing = bsd
   printcap name = /dev/null
   disable spoolss = yes
   show add printer wizard = no

   comment = Home Directories
   browseable = no
   read only = yes
   create mask = 0700
   directory mask = 0700
   valid users = %S

   comment = All Printers
   browseable = no
   path = /var/spool/samba
   printable = yes
   guest ok = no
   read only = yes
   create mask = 0700

   comment = Printer Drivers
   path = /var/lib/samba/printers
   browseable = yes
   read only = yes
   guest ok = no

also i checked that my user is in sambashare group and the directory /var/lib/samba/usershares has the following attributes
drwxrwxrwx 2 root sambashare 4096 فبر 5 19:11 usershares

any suggestion with this issue?

Who owns the files here: /var/lib/samba/usershare/ ?

When I had a similar issue, error 255, the problem file there was owned by root when it should have been owned by me as the user.

@ jrichard326 I don’t think this is the problem. I tried with sudo chown -R $USER:sambashare /var/lib/samba/usershares and same problem occurs

I was referring to the files inside that folder. On my system the folder itself is owned by root. The files inside that folder are owned by me.

Likely, the following link will fix this issue:

Add this option under the [global] section:

    client ipc signing = auto
 then restart samba (systemctl restart smb.service) or reboot

i tried this one and still issue not resolved