Can't add folders or files to partition

i can’t add folders or files to my partitions,
i looked into it and i think i might be able to fix it by changing ownership, only problem is i have no idea how to use sudo chown command, any help?

Hi @AlphaN00b,

This sounds like a permission problem, yes.

  • Is the drive newly partitioned and/or formatted?
  • What is the mount point you are trying to write to?
  • Can you create a file/directory on it with root?
sudo chown -R USER:USER /media/data

Actually, no. It’s:

sudo chown -R <user>:<group> /media/data


  • sudo runs the command as root, the superuser, with the highest privileges.
  • chown is CHange OWNer(ship?)
  • <user> is the username of the user which you want to transfer ownership to.
  • <group> is the group you want to transfer ownership to.
  • /media/data is the path of the file/directory of ownership will be transferred.
  • -R stand for recursive and means ALL of the path’s files and sub-directories will have their ownership transferred as well.

Hope this makes some sense at least.

sudo chown -R $USER:$USER /media/data

The $ in that instance will automatically chose/set the user and group is running the command. :slight_smile:


Thank you!
I did wonder about it, but it was no real concern.

No worries. Your command and explanation is perfect for someone new to linux, more beneficial for OP. :wink:

Just read your answer a few times, and I see what you are saying only now.
But, thank you, I’ve learnt something new today, so it’s been a good day according to me.

EXACTLY why I did it. I remember how I struggled when I started using Linux. Hell, I still struggle. I’m not all-knowing.

1 Like

Nobody is :smiley:

That’s true. Just more people should admit they aren’t and not be afraid to learn. That’ll make the whole world a different and better place…

Most commands have a manual. :wink:
man chown

1 Like

so i did what you guys said and that did not fix it because apparently the partition is set to read-only:

chown: changing ownership of ‘/mnt/sda3/’: Read-only file system

anyone know how to change that?

yeah i will check them out later but for now i just want to get the system working properly to get used to it :confused:

the drive is not newly partitioned nor formatted, i was actually trying to dual boot my laptop and accidentally installed manjaro on the windows partition and it’s the only one that got formatted,
the partitions that are set to “read-only” didn’t go through any changes.

this is the mount point(if i understand what it is right): /mnt/sda3/

and no, i tried creating files with root but didn’t work

This is what you should’ve started with.

well idk,
currently i’m formatting one of the partitions bc from what i understood of what i found is that i have to change it from ntfs to whatever work with linux, hopefully that will fix it.

You don’t have to, you can install ntfs-3g, but ntfs may not always work as well as a native filesystem. Always best to use native stuff when possible. :slight_smile:

If you format it with a suitable filesystem and then change the ownership/permissions to suit your use case properly then you will indeed be able to write files there. :slight_smile:

i do acually have ntfs-3g installed, i installed it before i tried to do anything.
anyway formatting it into a linux filesystem fixed the problem and i can create and add files now.

thanks everyone for your help

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.