Can't add Brother DCP-7030


I installed, the AUR package, which showed no error. The printer gets shown in the devices list when I click add printer in the settings menu. If I try to add the printer, I get the error message

Failed to add the printer

How can I debug it?

Did you try in your browser:

then Administration-Add Printer or Manage printer?

Also be sure that CUPS is installed and running.

in terminal: systemctl -a | grep cups

This manual intervention was required quite awhile ago:

sudo systemctl disable --now org.cups.cupsd.socket
sudo systemctl disable --now org.cups.cupsd.service
sudo systemctl disable --now org.cups.cupsd.path
sudo systemctl enable --now cups.service
sudo systemctl enable --now cups.socket
sudo systemctl enable --now cups.path
1 Like

I overlooked the top navigation bar (and wondered how to use that page :smiley: ).

Using the CUPS web interface worked.

cups.service|path|socket were all loaded and enabled. The disable and enable intervention didn’t do anything. I don’t know what the problem with the graphical UI is.

Anyway. It works now. Thanks!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.