Can't access, from Librewolf or Brave

As the title states, so far I’ve found two sites I just can’t open for some reason. The page just keeps on loading perpetually but that’s it.

I could access these sites from phone over the same network so it isn’t my network.

I tried disabling extensions like Decentraleyes, Ublock, Privacy Badger, Dark Reader etc., installed a new browser (Firefox) from the repo, uninstalled (and deleted their saved files) & reinstalled both the browsers but failed to fix the problem so far.

For some reason though appimage of Librewolf worked somehow.

Please don’t suggest something like- “Just use any Youtube Instance.” I want to fix this problem as earlier it was only Youtube but now IMDB also doesn’t load; seems like the problem is getting bigger.

Thank you so much for your time and if you require any additional info, do tell.

[SOLVED] Not really though. I just forgot about Timeshift. Fortunately it fix whatever was broken. PLEASE INSTALL TIMESHIFT; IT WILL SAVE YOUR ASS!

edit: didnt notice that also brave is affected

Can you successfully ping them?

ping -c4
ping -c4

I suggest you take a look at your dns resolver.

If you cannot access 1 out 100 sites - it is a dns issue. Use below guide to troubleshoot

As I mentioned above I can easily access them via phone over the same wifi network. Also for some reason, using appimage of Librewolf also worked but a native fresh install of Firefox didn’t work out.

Pinging them is also not a problem for me.

I can access them with my phone no problem. In fact, for some reason, appimage of Librewolf works but a fresh native install of Firefox doesn’t.

But your phone’s dns is not your computer’s dns (not necessarily) - you cannot use that as an indicator.

You have to rely on some terminal-fu and network knowledge to find the answer.

Oh, I apologies for my misunderstanding.

I can ping those sites no problem if that helps.

If you can ping them by name then dns is working.

If you cannot open the page in a browser then something in your browser is blocking.

Rest assured that the behavior is not normal.

It has been - is caused by some configuration you have inplemented - what, how, when and where - I have no idea.

My suggestion would be to ensure a clean install of your preferred browser.


Create a new user - login as the user - and test the browser using the same sites that fails when logged in as your primary user.


Earlier, I ran -Rns and uninstalled both Librewolf and Brave. Furthermore, cleaned every file left over in /home. Should I do it once more because this didn’t work out earlier?

If there is anything like the purge command in Ubuntu based systems which could help out, please do tell.

One more thing- I have to disable OCSP because otherwise I can’t access my network login page.

Is your network running under a proxy of some sorts?

So some entity is controlling your network access - if you are on a corporate or campus network - perhaps even some public networks on libraries and cafe’s - they may have deliberately blocked access to e.g. youtube because they have a legitimate interest in blocking certain sites - in which case you need to ask the provider behind the login page.

Please check if ca-certificates is installed, too. That could be the reason why the appimage was working.

Fortunately that isn’t the case as everyone else can access these sites.

Never mind, my dumb ass just forgot about Timeshift; ran it and the peace has been restored.

Thank you and apologies for everything.