Can't access ext4 partition from my laptop

I boot my Manjaro PC off a 120GB USB, no problem. It has 3 unencrypted partitions:

fat32 /boot/efi
ext4 /

Last night I tried to access the ext4 files from my Manjaro laptop but I couldn’t mount it. I’m not sure why. Anyway, I’m wondering if I could add another partition just for copying files between computers. Of course I could use a 2nd USB drive, but I’m still wondering how to do this with one USB.

For comparison, I have another Manjaro USB with just one ext4 partition and other computers can mount it.

So I’m thinking maybe one of the extra partitions (the boot or swap) is blocking me from mounting the ext4. Is that something I can safely “undo” or not worth the trouble?

Now I’m starting to think it was my laptop’s fault… the USB that mounts on my PC does not mount on my laptop… which doesn’t make much sense. I went through all the BIOS settings and found nothing useful.

OK figured it out…

  1. I used gparted, nice tool. First created a GPT partition table, then added an ext4 partition. I like adding a label, because then you can find it under /dev/disk/by-label and so on.
  2. This mounted on my PC fine, but I couldn’t move files inside Thunar to the USB. Solution, it was just a permission problem.
  3. I’m not sure why my PC is different, but Thunar automatically finds the USB on my PC. On my laptop, I had to create an fstab entry and set “user” as an option, otherwise it says I must be root to mount the USB.

Well, this doesn’t exactly solve my original question. Originally, I wanted to see if I could mount an existing bootable Manjaro USB. I gave up and formatted a clean USB and mounted that instead. I have a feeling these ‘solutions’ (#2 and #3) would have solved my original problem, I’ll try again later.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.