Canon Pixma TS5350 Only selects rear tray

Hi,
I have installed my Canon Pixma TS5350 successfully as a wifi network printer on my XFCE installation and it printed out the test page from the front tray (its on shelves without space to access the rear tray)
However, when I try to print from Mousepad or anything else it tries to print from rear tray
I have tried with Paper Source set as Auto and Front (and even Rear)
Any ideas please?

Change the defaults using cups localhost:631

Thanks -
I worked out the following using your post as a starting point

Looked in /etc/cups/printers.conf for my printer name:
<DefaultPrinter Canon-TS5300-series>

To find what options available for my printer:
lpoptions -p Canon-TS5300-series -l

The one I wanted:
InputSlot/Media Source: Auto Main *Rear

I guessed the * was the set one and then found how to change it:
sudo lpadmin -p Canon-TS5300-series -o InputSlot=Rear

Changed it back to Main:
sudo lpadmin -p Canon-TS5300-series -o InputSlot=Main

Checked:
lpoptions -p Canon-TS5300-series -l
InputSlot/Media Source: Auto *Main Rear

Restarted cupsd
sudo systemctl restart cups.service

Enabled cupsd (for luck):
sudo systemctl enable cups.service

Checked default
lpoptions -p Canon-TS5300-series -l
InputSlot/Media Source: Auto *Main Rear

So, it seems my default is Main, and was always Main as indicated in the GUI Printer Properties, but it still tries to print from the Rear tray from Mousepad or any other app :confused:

Any more ideas, please?

EDIT:
I tried to print a file using lp:
lp Prescription.txt

This ‘printed’ from the correct Main front tray but it was a blank sheet

Print Test Page from the GUI Print Settings still works from front tray and prints.

EDIT 2:
DOH!
I finally saw the tabs at the top of the page and got to http://localhost:631/printers/
However, using this way to set the default tray still gave no luck - it still tries to print from Mousepad to the Rear tray when Main tray is selected

The info it gives me is:

Description: Canon TS5300 series
Location: Office
Driver: Canon TS5300 series, driverless, cups-filters 1.28.5 (color, 2-sided printing)
Connection: dnssd://Canon%20TS5300%20series._ipp._tcp.local/?uuid=00000000-0000-1000-8000-00188b0431b4
Defaults: job-sheets=none, none media=iso_a4_210x297mm sides=one-sided

i.e. no default mention of ‘InputSlot’

Also, why is this ‘driverless’?

EDIT 3!
I saw there was also an option for ‘Print to LPR’ in the Mousepad print for a TXT file and this also printed from the correct Main tray but it was just a blank page

I tried the same ‘Print to LPR’ for a jpg file in Shotwell Viewer and this worked from the right tray and printed!

Trying lp or lpr for a TXT or a JPG file from the terminal printed from the right tray but both gave a blank sheet.

I am lost :smile:

1 Like

Pretty much if I ‘Print to LPR’ it prints from the correct tray