Cannot use Picom instead of Xfwm4

I tried to install Picom and disable Xfwm4 by following this guide: Using Compton for a tear-free experience in Xfce - Manjaro
I have successfully installed Picom, edited picom.conf, added Picom to autostart and disabled Xfwm4 with xfconf-query -c xfwm4 -p /general/use_compositing -s false command (there was no output from it, but the Xfwm4 effects were disabled, so I don’t know if it worked or not). However, neofetch is saying that Xfwm4 is still used and pgrep -l picom outputs nothing. What should I do to make picom work?

my inxi -Fazy if it’s useful:

  Kernel: 6.9.2-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 14.1.1
    clocksource: tsc avail: hpet,acpi_pm
    parameters: BOOT_IMAGE=/boot/vmlinuz-6.9-x86_64
    root=UUID=3b4b084b-ae86-4409-8160-4658e43398cc rw quiet splash apparmor=1
    security=apparmor udev.log_priority=3
  Desktop: Xfce v: 4.18.1 tk: Gtk v: 3.24.36 wm: xfwm4 v: 4.18.0
    with: plank,xfce4-panel tools: xfce4-screensaver vt: 7 dm: LightDM v: 1.32.0
    Distro: Manjaro base: Arch Linux
  Type: Desktop System: Aquarius product: Aquarius Pro, Std, Elt Series v: N/A
    serial: <superuser required>
  Mobo: ASUSTeK model: B85M-E v: Rev X.0x serial: <superuser required>
    part-nu: All uuid: <superuser required> UEFI: American Megatrends v: 3602
    date: 04/04/2018
  Info: model: Intel Xeon E3-1270 v3 bits: 64 type: MT MCP arch: Haswell
    level: v3 note: check built: 2013-15 process: Intel 22nm family: 6
    model-id: 0x3C (60) stepping: 3 microcode: 0x28
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
    L3: 8 MiB desc: 1x8 MiB
  Speed (MHz): avg: 1264 high: 3900 min/max: 800/3900 scaling:
    driver: intel_cpufreq governor: schedutil cores: 1: 3900 2: 881 3: 800 4: 798
    5: 937 6: 800 7: 1198 8: 800 bogomips: 55899
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Type: gather_data_sampling status: Not affected
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: mmio_stale_data status: Unknown: No mitigations
  Type: reg_file_data_sampling status: Not affected
  Type: retbleed status: Not affected
  Type: spec_rstack_overflow status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Retpolines; IBPB: conditional; IBRS_FW;
    STIBP: conditional; RSB filling; PBRSB-eIBRS: Not affected; BHI: Not
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
  Device-1: NVIDIA GM206 [GeForce GTX 960] vendor: Gigabyte driver: nvidia
    v: 550.78 alternate: nouveau,nvidia_drm non-free: 545.xx+ status: current
    (as of 2024-04; EOL~2026-12-xx) arch: Maxwell code: GMxxx
    process: TSMC 28nm built: 2014-2019 pcie: gen: 1 speed: 2.5 GT/s lanes: 16
    link-max: gen: 3 speed: 8 GT/s ports: active: none off: HDMI-A-1
    empty: DP-1,DVI-D-1,DVI-I-1 bus-ID: 01:00.0 chip-ID: 10de:1401
    class-ID: 0300
  Display: x11 server: v: with: Xwayland v: 24.1.0
    compositor: xfwm4 v: 4.18.0 driver: X: loaded: N/A failed: nvidia
    gpu: nvidia,nvidia-nvswitch display-ID: :0.0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-size: <missing: xdpyinfo>
  Monitor-1: HDMI-0 res: 1920x1080 dpi: 93 size: 527x296mm (20.75x11.65")
    diag: 604mm (23.8") modes: N/A
  API: EGL v: 1.5 hw: drv: nvidia platforms: device: 0 drv: nvidia device: 2
    drv: swrast gbm: drv: kms_swrast surfaceless: drv: nvidia x11: drv: nvidia
    inactive: wayland,device-1
  API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: nvidia mesa v: 550.78 glx-v: 1.4
    direct-render: yes renderer: NVIDIA GeForce GTX 960/PCIe/SSE2
    memory: 3.91 GiB
  API: Vulkan v: 1.3.279 layers: 10 device: 0 type: discrete-gpu
    name: NVIDIA GeForce GTX 960 driver: nvidia v: 550.78 device-ID: 10de:1401
    surfaces: xcb,xlib
  Device-1: Intel 8 Series/C220 Series High Definition Audio vendor: ASUSTeK
    driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:8c20
    class-ID: 0403
  Device-2: NVIDIA GM206 High Definition Audio vendor: Gigabyte
    driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
    bus-ID: 01:00.1 chip-ID: 10de:0fba class-ID: 0403
  API: ALSA v: k6.9.2-1-MANJARO status: kernel-api with: aoss
    type: oss-emulator tools: alsactl,alsamixer,amixer
  Server-1: sndiod v: N/A status: off tools: aucat,midicat,sndioctl
  Server-2: JACK v: 1.9.22 status: off tools: N/A
  Server-3: PipeWire v: 1.0.7 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    tools: pactl,pw-cat,pw-cli,wpctl
  Device-1: Realtek RTL8111/8168/8211/8411 PCI Express Gigabit Ethernet
    vendor: ASUSTeK P8 series driver: r8169 v: kernel pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 port: d000 bus-ID: 03:00.0 chip-ID: 10ec:8168
    class-ID: 0200
  IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Info: services: NetworkManager,systemd-timesyncd
  Device-1: Realtek Bluetooth Radio driver: btusb v: 0.8 type: USB rev: 1.1
    speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 3-10:5 chip-ID: 0bda:8771
    class-ID: e001 serial: <filter>
  Report: rfkill ID: hci0 rfk-id: 0 state: up address: see --recommends
  Local Storage: total: 1.26 TiB used: 250.52 GiB (19.4%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/sda maj-min: 8:0 vendor: Apacer model: AS340 240GB
    size: 223.57 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    tech: SSD serial: <filter> fw-rev: 1A0 scheme: GPT
  ID-2: /dev/sdb maj-min: 8:16 vendor: Western Digital model: WD10EALX-009BA0
    size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    tech: N/A serial: <filter> fw-rev: 1H15 scheme: GPT
  ID-3: /dev/sdc maj-min: 8:32 model: SSD 128GB size: 119.24 GiB block-size:
    physical: 512 B logical: 512 B speed: 6.0 Gb/s tech: SSD serial: <filter>
    fw-rev: XKR scheme: GPT
  ID-4: /dev/sdd maj-min: 8:48 vendor: Move Speed model: SD size: 14.65 GiB
    block-size: physical: 512 B logical: 512 B type: USB rev: 2.0 spd: 480 Mb/s
    lanes: 1 mode: 2.0 tech: N/A serial: <filter> fw-rev: 5.00 scheme: MBR
  ID-1: / raw-size: 118.95 GiB size: 116.52 GiB (97.96%)
    used: 39.06 GiB (33.5%) fs: ext4 dev: /dev/sdc2 maj-min: 8:34
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 296 KiB (0.1%) fs: vfat dev: /dev/sdc1 maj-min: 8:33
  Alert: No swap data was found.
  System Temperatures: cpu: 45.0 C mobo: N/A gpu: nvidia temp: 39 C
  Fan Speeds (rpm): N/A gpu: nvidia fan: 40%
  Memory: total: 16 GiB available: 15.52 GiB used: 2.75 GiB (17.8%)
  Processes: 287 Power: uptime: 12m states: freeze,mem,disk suspend: deep
    avail: s2idle wakeups: 0 hibernate: platform avail: shutdown, reboot,
    suspend, test_resume image: 6.18 GiB services: upowerd,xfce4-power-manager
    Init: systemd v: 255 default: graphical tool: systemctl
  Packages: pm: dpkg pkgs: 0 pm: pacman pkgs: 1469 libs: 502 tools: pamac,yay
    pm: flatpak pkgs: 0 Compilers: gcc: 14.1.1 Shell: Zsh v: 5.9
    running-in: alacritty inxi: 3.3.34

Hi @watislan,

Yo0u did restart afterwards, correct?

Yes, I tried both logging out and rebooting

Please provide the output of:

cat ~/.config/autostart/picom.desktop
[Desktop Entry]
Comment=X11 compositor
Exec=compton -b

It’s all completely the same as in the guide I’ve linked, except I tried to change picom version, but it did nothing.

According to thee ubuntu forums:

Open the XFCE settings manager: settings manager > session and startup > application autostart > add and add compton -b. Now compton will start automatically when you login.

It was already there since I created ~/.config/autostart/picom.desktop

AH, well, that was the instructions I got. I have one possibly last thing to check, that might be it or it might not. What happens, post any output you get when running:

compton -b

…in the terminal.

[ 08.06.2024 17:50:01.661 parse_config_libconfig FATAL ERROR ] Error when reading configuration file "/home/varg/.config/picom/picom.conf", line 6: syntax error
[ 08.06.2024 17:50:01.661 main FATAL ERROR ] Failed to create new session.

There you have it: syntax error on line 6.

1 Like

There’s the problem. Please post the output of:

cat /home/varg/.config/picom/picom.conf


sed '6q;p' /home/varg/.config/picom/picom.conf

cat /home/varg/.config/picom/picom.conf:

backend = "glx";
glx-no-stencil = true;
vsync = true;
unredir-if-possible = true;

shadow = false;.
shadow-radius = 7;
shadow-offset-x = -7;
shadow-offset-y = -7;
shadow-exclude = [
  "class_g ?= 'Cairo-dock'",
  "class_g ?= 'Xfce4-notifyd'",
  "class_g ?= 'Xfce4-power-manager'",
  "class_g ?= 'Notify-osd'",

detect-client-opacity = true;

  dock = { shadow = false; };
  dnd = { shadow = false; };
  tooltip = { shadow = false; };

sed ‘6q;p’ /home/varg/.config/picom/picom.conf:

backend = "glx";
backend = "glx";
glx-no-stencil = true;
glx-no-stencil = true;
vsync = true;
vsync = true;
unredir-if-possible = true;
unredir-if-possible = true;

shadow = false;.

ow, there was a period at the end of line. Looks like it’s left after i’ve deleted comments. I’ll delete it and try again

Was about to point this out:

So remove it and try again.


So I deleted this period, checked if there was no other typos, ran xfconf-query -c xfwm4 -p /general/use_compositing -s false and rebooted. My wm is still Xfwm and compton -b outputs this:

[ 08.06.2024 18:35:44.893 session_init WARN ] This compositor has been renamed to "picom", the "compton" binary will not be installed in the future.
[ 08.06.2024 18:35:44.904 session_init FATAL ERROR ] Another composite manager is already running


xfconf-query --channel=xfwm4 --property=/general/use_compositing --set=false

From: [xubuntu] Screen tearing



Otherwise see if you can find and turn it off somewhere using:


As per

Or the graphical way - if it is installed:
xfwm4 on the left – and use_compositing on the right
remove the checkmark


none of that worked for me. Xfwm is still used somehow, and picom won’t run

Hmmm…OK, honestly, I don’'t know what this’ll break or not, but you can try:

kill -9 `pidof xfwm4` && picom

And see what that does…(remember to provide the output.)

Tried it, windows panels disappeared for a moment, went back and output gave the same error as before

[ 08.06.2024 19:16:37.530 session_init FATAL ERROR ] Another composite manager is already running

Looks like Xfwm was killed, instantly turned back on and after that picom tried to run. That made me giggle

Please provide the output of:

cat /etc/xdg/xfce4/xfconf/xfce-perchannel-xml/xfce4-session.xml


From ask ubuntu:

Because in XFCE it is common for us to save our session while logging out, don’t forget to clean your session: Settings Manager->Session and Startup->Session tab->Clear saved sessions