Cannot update anymore; violation of dependencys db=5.3.28, required by lib32-db

Hi anyone,

when pacman -Syu I am getting an error message:

Fehler: Vorgang konnte nicht vorbereitet werden (Kann Abhängigkeiten nicht erfüllen)
:: Installation von db (6.2.32-1) verletzt Abhängigkeit »db=5.3.28«, benötigt von lib32-db

Error: Failed to prepare operation (Cannot satisfy dependencies).
:: Installation of db (6.2.32-1) violates dependency “db=5.3.28” required by lib32-db

what can I do?

You have installed some package from the AUR, which requires this one.
This one is itself a package from the AUR - not one from the standard repositories.
Remove that package - or try removing lib32-db and see what objects to you trying to remove it.

If you share the whole output of the entire update
instead of just the one line above
you will probably see it.

It might be ceph-libs, from what I have seen here on multiple occasions.

Thank you. lib32-db seem not to be found…

sudo pacman -R lib32-db
[sudo] Password for jonas: 
Error: Target not found: lib32-db

Apparently it indeed isn’t - which does not make sense to me.

perhaps there is some clue in there?

What got updated so far?
It has got something to do with some AUR package that you have or had.

Try refreshing your mirror list and run the update again with
pacman -Syyu

Looks like lib32-lib was dropped to AUR recently: only one commit at: 2022-12-21

So I would suggest remove db, do a full upgrade and install db again if you need it.

Removing db also did not work

sudo pacman -R db
[sudo] password for jonas: 
Checking dependencies ...
Error: Could not prepare operation (Cannot satisfy dependencies).
:: Removing db violates dependency "db>=4.7", needed by samba

I disabled AUR in my system. After that the update worked flawless. I know its not the ideal solution.

That surprises me. I don’t believe you use pacman for an update, but pamac. Just to be clear: pacman is not pamac.