"Cannot unmount Temporary Directory (/tmp)" while shutting down

So, i recently switched from arch ot manjaro. I couldn’t shut it down properly, because it couldn’t unmount /tmp and was waiting for process Xorg. Now that i tried shutting down manjaro, it did the exact same thing.
Did someone encounter this problem before?

Thanks in advance.

Hello,

Without more information on your system, what error messages are you getting. It is not easy to help with a solution. Do you have running programs when trying to shut down? What video driver are you using? What desktop are you running?

Have you check with the monitor program to see what is running, but may be stuck?

Hello, and thank you for your reply
I am a relatively new linux user and don’t really know which logs might be relevant and how to view them.
What i can give you is the output it gives me when shutting down:

[FAILED] Failed unmounting /home.
[FAILED] Failed unmounting Temporary Directory (/tmp).
[ 1130.019395] systemd-shutdown[1]: Waiting for process: Xorg
[ 1220.025196] systemd-shutdown[1]: Waiting for process: Xorg
[ 1228.487994] INFO: task Xorg: 1248 blocked for more than 122 seconds.
[ 1228.488060] Tainted: P OE 5.8.6-1-MANJARO #1
[ 1228.488116] “echo 0 > /proc/sys/kernel/hung_task_timeout_secs” disables this message.

and then it starts throwing some HEX values in an endless loop.

edit: formatting
edit 2: Also i have additionally tried to install proprietary Nvidia drivers, but according to a journal i was able to look at it looks like it is running on Noveau

:+1: Welcome to Manjaro! :+1:

Please read this:


and post some more information so we can see what’s really going on. Now we know the symptom of the disease, but we need some more probing to know where the origin lies…
  • An inxi --admin --verbosity=7 --filter --no-host would be the minimum required information… (Personally Identifiable Information like serial numbers and MAC addresses will be filtered out by the above command)
  • In your particular case, the contents of your fstab and /etc/X11/xorg.conf.d/90-mhwd.conf would be beneficial as well.

:innocent:

1 Like

Ok so the problem ended up being in the proprietary Nvidia drivers, switching it to Noveau fixed the problem.

Thank you all for replies!

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.