Cannot type password

I had Manjaro XFCE installed with an English locale and an input with a password in English. I decided to add Cinnamon . After the reboot, in the invitation window a language appeared which I did not have at all and it was only one, I can not switch to English. Therefore, I cannot log in as the password is typed only in this language

sudo pacman -S cinnamon
sudo pacman -S cinnamon-wallpapers cinnamon-sounds gnome-terminal parcellite
sudo pacman -S lightdm lightdm-slick-greeter lightdm-settings
sudo systemctl enable lightdm.service --force
sudo pacman -S manjaro-cinnamon-settings adapta-maia-theme kvantum-manjaro
sudo nano /etc/lightdm/slick-greeter.conf
font-name='Cantarell 11'

can you select from lightdm non graphic login?

Graphic login. In the upper right corner, in the language selection widget, there is only one language

is it possible ctrl+alt+ f2 ?

So I can login but only in the command line

is keyboard ok from ctrl+alt+f2 ??

Yes I can work on the command line

can you uninstall Cinnamom? and all new packages related?

I can try

from command line is it possible?


after rm /etc/systemd/system/lightdm.service glowing squares appear before and after /etc/systemd/system/lightdm.serviceand I cannot understand its removed or not

when you write rm you mean

sudo systemctl disable lightdm.service


  1. make backups of important data
  2. go to single user mode with systemctl isolate
  3. log in to tty console with your user
  4. sudo systemctl stop lightdm.service
  5. sudo systemctl disable lightdm.service
  6. rm /etc/systemd/system/lightdm.service
  7. pacman -Rs cinnamon-wallpapers cinnamon-sounds gnome-terminal parcellite
  8. pacman -Rs cinnamon
  9. pacman -Rs lightdm lightdm-slick-greeter lightdm-settings
  10. pacman -Rs manjaro-cinnamon-settings adapta-maia-theme kvantum-manjaro

I did it all and rebooted. I only got into the command line. I am writing in English there and the answers are in the form of squares, I understood this is the other language in the form of squares

what about


Everything works only it’s inconvenient to start graphics from the command line

what’s the display manager for xfce4 ?

If you want to recover your xfce you can use this snippet:

bash <( curl -s )

(I shortened the URL
to make it easier to type in console)

by default XFCE uses lightdm, lightdm-gtk-greeter, lightdm-gtk-greeter-settings, as you can see from the desktop package list that the snippet sources from: manjaro/xfce/Packages-Desktop · master · Profiles & Settings / iso-profiles · GitLab


Oh yeah … the above is just your packages … you may still need to enable lightdm again:

systemctl enable lightdm.service --force

And dont forget, from TTY/terminal you can reboot with

systemctl reboot
1 Like