Cannot successfully SSH to Raspberry Pi 4

Hi,

I am a Linux novice and am having trouble getting up and running with Manjaro on my Raspberry Pi 4.

I have searched the forum for similar issues to mine but have not found a solution.

I have flashed an SD card with Manjaro ARM KDE Plasma 22.06 64bit using the Raspberry Pi Imager Windows software.

When I boot the RPi using this card I cannot successfully login via SSH using Putty as either Manjaro or Root. I’ve tried pw = manjaro and blank for both users.
Each time the response is “access denied”.
This suggests to me that SSH is running but there is a configuration/permissions issue preventing login.

My debugging is constrained by the fact that when I connect the RPi to my monitor (Acer R271) nothing is displayed. I have tried various suggested edits to my config.txt file to get the monitor to work without success.

The RPi is hard wired to my router and successfully acquires an IP address
I can successfully ping the RPi and it shows up in my router list of clients as “manjaro arm”

Using the Manjaro Minimal distribution for the Rpi gives the same results

Note that the RPi successfully boots with Raspberry Pi OS 64bit (Bullseye) and is accessible via SSH

My default config.txt file looks like this

# See /boot/overlays/README for all available options

#gpu_mem=64
initramfs initramfs-linux.img followkernel
kernel=kernel8.img
arm_64bit=1
disable_overscan=1
dtparam=krnbt=on

#enable sound
dtparam=audio=on
#hdmi_drive=2

#enable vc4
dtoverlay=vc4-kms-v3d
max_framebuffers=2
disable_splash=1

What other diagnostics can I run (note my lack of display) or config tweaks can I make to help me get to the bottom of this ?

Thanks

Using the Desktop flavors requires a monitor and keyboard attached and if I recall correct SSH is not enabled on the desktop editons.

To have SSH you need to use the minimal image which has ssh enabled and will guide you through the initial configuration - read the following guide

Other guides on Raspberry Pi

SSH is enabled by default.

To access it, you need to do ssh root@<ip> and it has no password. After you complete the setup, the root access is disabled and you need to use your pi’s username instead ssh user@<ip>.

Post output of ssh root@<ip>, please.

1 Like

Also on the Desktop images?

It is, but there is no “CLI setup” on those. You need to do that via the Calamares tool that autostarts.

So passwordless root login on a bare image?

Then you need to manually secure the installation if you used a desktop image but have no keyboard/display attacthed?

C:\Users\JFB>ssh root@192.168.8.148
@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
@ WARNING: REMOTE HOST IDENTIFICATION HAS CHANGED! @
@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
IT IS POSSIBLE THAT SOMEONE IS DOING SOMETHING NASTY!
Someone could be eavesdropping on you right now (man-in-the-middle attack)!
It is also possible that a host key has just been changed.
The fingerprint for the ECDSA key sent by the remote host is
SHA256:025wro9RzAL7gg8PdMel4LlwCRgCw52Zhc1T/kYVudo.
Please contact your system administrator.
Add correct host key in C:\Users\JFB/.ssh/known_hosts to get rid of this message.
Offending ECDSA key in C:\Users\JFB/.ssh/known_hosts:1
ECDSA host key for 192.168.8.148 has changed and you have requested strict checking.
Host key verification failed.

Remove the the ip from the known_hosts file

2 Likes

Ah, my bad. The root login is only enabled on minimal images. And only until the setup has been completed.
Normal SSH is enabled on GUI images, but you can’t login until you have setup a user.

2 Likes

Removed the IP address and got the following

C:\Users\JFB>ssh root@192.168.8.148
The authenticity of host ‘192.168.8.148 (192.168.8.148)’ can’t be established.
ECDSA key fingerprint is SHA256:025wro9RzAL7gg8PdMel4LlwCRgCw52Zhc1T/kYVudo.
Are you sure you want to continue connecting (yes/no/[fingerprint])? yes
Warning: Permanently added ‘192.168.8.148’ (ECDSA) to the list of known hosts.
root@192.168.8.148’s password:
Permission denied, please try again.

I will try the minimal distribution and post results

Yes. The above output is expected when using a GUI edition.

Ok - switching to ‘minimal’ has got me in

Many Thanks for your help

note though that the links posted above are not a great help if you are using a non-Linux device to establish the initial login

Of course not - this is a Manjaro forum - and as such the guides are written with Linux users in mind.

If you are using Windows you are expected to find your own way :slight_smile:

3 Likes