Cannot start Krita

Hi, I cannot start krita, because it instantaneously segfaults on my manjaro machine:
5.8.9-2-MANJARO, krita 4.3.0-2, qt5-base 5.15.1-1, Cinnamon (not Deepin)

fish: 'krita' terminated by signal SIGSEGV (Adressbereichsfehler)

Thread 1 "krita" received signal SIGSEGV, Segmentation fault.
0x0000005555570028 in ?? ()
(gdb) bt full
#0  0x0000005555570028 in ?? ()
No symbol table info available.
#1  0x00007fffef211b1c in deepin_platform_plugin::DHighDpi::logicalDpi(QXcbScreen*) () from /usr/lib/qt/plugins/platforms/
No symbol table info available.
#2  0x00007ffff4fcd582 in ?? () from /usr/lib/
No symbol table info available.
#3  0x00007ffff4f7b9e3 in QWindowSystemInterface::handleScreenAdded(QPlatformScreen*, bool) () from /usr/lib/
No symbol table info available.
#4  0x00007fffef0a46a1 in QXcbConnection::initializeScreens() () from /usr/lib/
No symbol table info available.
#5  0x00007fffef07f338 in QXcbConnection::QXcbConnection(QXcbNativeInterface*, bool, unsigned int, char const*) () from /usr/lib/
No symbol table info available.
#6  0x00007fffef0820f5 in QXcbIntegration::QXcbIntegration(QStringList const&, int&, char**) () from /usr/lib/
No symbol table info available.
#7  0x00007fffef20b8b1 in deepin_platform_plugin::DPlatformIntegration::DPlatformIntegration(QStringList const&, int&, char**) () from /usr/lib/qt/plugins/platforms/
No symbol table info available.
#8  0x00007fffef20afc7 in DPlatformIntegrationPlugin::create(QString const&, QStringList const&, int&, char**) () from /usr/lib/qt/plugins/platforms/
No symbol table info available.
#9  0x00007ffff4f9a627 in QGuiApplicationPrivate::createPlatformIntegration() () from /usr/lib/
No symbol table info available.
#10 0x00007ffff4f9bb01 in QGuiApplicationPrivate::createEventDispatcher() () from /usr/lib/
No symbol table info available.
#11 0x00007ffff4bd2936 in QCoreApplicationPrivate::init() () from /usr/lib/
No symbol table info available.
#12 0x00007ffff4f9eb40 in QGuiApplicationPrivate::init() () from /usr/lib/
No symbol table info available.
#13 0x00007ffff4f9faa8 in QGuiApplication::QGuiApplication(int&, char**, int) () from /usr/lib/
No symbol table info available.
#14 0x00007ffff6f8f744 in KisOpenGLModeProber::probeFormat(KisOpenGL::RendererConfig const&, bool) () from /usr/lib/
No symbol table info available.
#15 0x00007ffff6f78b3c in KisOpenGL::selectSurfaceConfig(KisOpenGL::OpenGLRenderer, KisConfig::RootSurfaceFormat, bool) () from /usr/lib/
No symbol table info available.
#16 0x0000555555e26dd1 in main ()
No symbol table info available.

Do other Qt applications work? Can you try krita-git from AUR?

Just tested on XFCE testing branch… no issue.

krita --version
No "breeze" available.
Set style "fusion"
krita 4.3.0

Which package did you use? Official repo? Flatpak? AUR?

Welcome to the forum! :wink:

Note: I’ve edited your post to properly format the output. Please use the </> button in the toolbar for pasting terminal output into your posts. :wink:

That said, Krita is working well here in a fully updated Manjaro Stable with Plasma 5.19.5, running on top of a 5.4 LTS kernel. :man_shrugging:

Probably your locale misconfigured.

I just tried kdenlive, it starts.
It took some time to compile the git-version, but I got the same error.

I used the official repo / and the aur-git-variant.

These are my locale settings. Can you tell me if these are wrong?

> locale


Did you just updated the system and didn’t reboot?

Reboot did not help.

Deepin platform plugin on Cinnamon?

You could also try starting with fresh settings.
Move ~/.config/kritarc and ~/.config/kritadisplayrc to another directory to back them up temporarily.

1 Like

I dont know, if there is a cinnamon language plugin, but that was what gdb said. I deleted the files but nothing changed.

Reproduced your issue.

Remove package with sudo pacman -Rs deepin-qt5platform-plugins

Still wonder how did that get installed on Cinnamon.


I have the same Problem. Segmentation Fault right after starting Krita. Unfortunately I can’t remove deepin-qt5platform-plugins as I’m using the Deepin DE and so it’s required by deepin-qt5integration which is required by other Deepin packages.
Does this mean that Krita and Deepin DE is not compatible to each other?

Yes! It works. I removed the package and its starting! Thank you so much!

Maybe the package got installed as a dependency of some programm that I once installed just to try. I remember installing different system information programs.

But why does krita use that plugin when I am not running deepin?

Hm, would it work with firejail --noprofile --blacklist=/usr/lib/qt/plugins/platforms/ krita

You might find community/deepin-qt5integration as well in the list of unused dependencies pacman -Qdt if you didn’t remove those.
Not familiar with the Kirta source, but seeing how it fails on Deepin as well, this might even be a Deepin issue.

Thanks for the suggestion!
I tested it and Krita starts… but as soon as I start interacting with it, Manjaro hangs up completely. The pointer moves but can’t activate any entry and the keyboard brings also nothing. I had to cold start the PC.
Seems like, there is a serious problem between Deepin and Krita.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.