Cannot solve an error in grub

Hello there.
I am using Manjaro kde plasma with Windows in dual mode.
It was working good without errors, But, one time when I tried to open the laptop this message appears

error : file '/boot/grub/x86_64-efi/normal.mod not found.
Entering rescue mode …
grub rescue>

I tried to boot in manjaro frome BIOS but I couldn’t. Then I tried to boot in Windows and it works.
I’ve searched a lot about this error and tried a lot of solutions but I still have the error and I am so bored about this error😓.
I’ve tried to use boot-repair software and the error haven’t been solved😔.
I also tried to use manjaro in live usb to access the old manjaro and edit somethings using chroot, but there was an error
error: target not found: mhwd-chroot
I’ve tried a lot of time to solve this error but I couldn’t :cry:.
Finally I just wanted to get the files inside Manjaro os to move them to external drive Because I wanted to format the drive where Manjaro is installed to solve the whole problem and install Manjaro again.
When I boot from live usb I found the drives of manjaro, but I can see only one file
Lost and found
And I cannot access any files

I tried to use a program in Windows called
Disk Internals but it shows only lost and found file

So could you please help me to solve this error Because I am very bored, I’ve searched a lot and wasted a lot of time to solve this problem but I couldn’t :persevere:

Because it should be manjaro-chroot … but that just automates chrooting a bit - you could always do it the ‘normal way’.

Otherwise refer to this post:

when I tried to use sudo manjaro-chroot -a
this error appears
==> ERROR: You can’t mount 0!

I will try your solutions and then update the topic here

Type 1 instead.

What version of the live USB are you using? That error you got should have been solve some months ago


I will try the newest version rightnow

Just to make sure we are talking about the same thing: I was referring to the “ERROR: You can’t mount 0!” error. As Wollie has mentioned, you can just answer 1 to question you are presented.

In any case, I recommend you to reinstall grub. If you are using UEFI (as it seems by your original grub error), something like:

grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=manjaro --recheck

and after that: