Cannot share a mounted drive

I have been using Manjaro for a few days now. Moved from windows. Already learned a lot, but I cannot figure out how to share a drive. I must be missing some option somewhere?
When I try to share via the file manager GUI I get an error:
Cannot modify the share:
‘net usershare’ returned error 255: net usershare add: cannot convert name “Everyone” to a SID. The transport-connection attempt was refused by the remote system… Maybe smbd is not running

I have spent the last hour googling, but nothing seems to work so far.
Help would be appreciated.

Hi, have you read the wiki?

Check if it is running:

sudo systemctl status smb.service

if not , then start and enable it:

sudo systemctl enable --now smb.service

… same for nmb.service

Yes I have.

Had to start and enable it, but it works now. Is there a need to do something so this stays permanent?

No, enable means it will start now on every boot and --now means it starts right now (same as systemctl start smb.service).

Maybe also do the same with nmb.service … which replies to NetBIOS over IP …

I assume it is the same command? I’ve been trying to deal with my storages all day. very frustrating :smiley: Everything seems needlessly complicated.

Yes, just: sudo systemctl enable --now nmb.service

Btw… after insallation of samba it should normally start after reboot. If you don’t want to restart then just start it manually with: sudo systemctl start smb.service

ok. done. I was able to share, but it still doesn’t mount on my nas. Is there a specific way to share all the subfolders as well or that is done by default?
Btw, I am trying to share my PC NTFS hard drive. Perhaps I should have mounted it to some folder? Now I just used whatever automatically showed up in the file browser window.

@enstain By default no dir should be shared… You can use a filemanager for this or do it the direct way with a text file and restart the smb.service:

Maybe you have to create the file in /etc/smb.conf …

I don’t understand half the words in that article… I guess Linux is still only for advanced users…

Nope… it is just the fact that more advanced users use linux and therefore love to do it this way and nothng is hidden behind a GUI…

However… I really have no idea what is running on your NAS and how you manage it there… so no idea here :man_shrugging:

The nas has a nice interface (qnap) and it has an app to mount samba shares. I just put in my pc IP address and username and password and it gets mounted. now it sais invalid so no idea either. It must be something missing on the Manjaro side.

@enstain Firewall, typo of the address ? Sorry but without information it just looking into a :crystal_ball:

It is on the same network. The firewall on Manjaro is disabled. It does see my PC, just gives an error that it is unable to connect…
I tried Ubuntu last week and it worked. Just had to press share in the GUI, but the overall interface was unbearable…

Have you checked the ownership and permissions of the directory you have mounted the NTFS drive to?

I once spent hours trying to sort out sharing only to discover that the owner of the directory was wrong.

Indeed good point… if you use the UserShare Feature @enstain then the user group of the files have to be sambashare also which is made with the filemanager automatically. On NTFS it is not possible and have to be done manually… NTFS Windows ACL s not compatible with linux ACL

Try it with with a folder on linux and it should work.

the owner is root. I tried changing the group to sambashare but it reverts back to root. I have mounted the drive to a folder, but the drives own folders are still inaccessible.

True… you can’t change it on NTFS at linux… you have to do it when mounting the NTFS partition as described at the wiki…

temprorary you can do it like this:

sudo mount -t ntfs-3g -o uid=1000,gid=1000 /dev/sdY1 /home/$USER/ntfs-partition

You have to create the folder ntfs-partition before.

With id you see the which id which group has.

But really… it is much easier to do it with ext4 filesystem than with ntfs… ntfs-3g is a reversed-engniered it works good, but has its limitations…