Cannot set LC_CTYPE to default locale no such file or directory

bug
manjaroarm

#1

Please supply this information when submitting a bug report.

  • What device are you using?
    Rpi 3B+

  • What edition of Manjaro-ARM is installed? (eg minimal, server, etc.)
    Manjaro-ARM-lxqt-rpi3-18.10.zip

  • When did you last run updates and reboot?
    Today 12.1.2019

  • What package contains the bug?
    Probably Manjaro Settings Manager / Locale Settings

  • Describe the bug the best you can. What where you doing when the bug happened?
    I used Manjaro Settings Manager to add a new language (Finnish) and then I set on the Detailed Settings tab “Language”, “Collation And Sorting”, “Messages” and “CType” to en_US.UTF-8. I want to write in Finnish so I set all the rest of the settings under “Formats” to fi_FI.UTF-8.

After that I started to get error messages from Perl that the locale was not set properly. The command: “locale” printed the error message that is the title of this bug report.

  • Any workarounds or known fixes?
    There are errors in two user files: ~/.config/lxqt/lxqt-config-locale.conf and ~/.config/lxqt/session.conf The locale settings lines has a non existing value that is a mixture of the English and Finnish locale: en_FI.UTF-8.

LANG=en_FI.UTF-8
LC_COLLATE=en_FI.UTF-8
LC_MEASUREMENT=en_FI.UTF-8
LC_MONETARY=en_FI.UTF-8
LC_NUMERIC=en_FI.UTF-8
LC_TIME=en_FI.UTF-8

After I corrected entries in both files as seen below, logged out and back in the problem was solved:

LANG=en_US.UTF-8
LC_COLLATE=en_US.UTF-8
LC_MEASUREMENT=fi_FI.UTF-8
LC_MONETARY=fi_FI.UTF-8
LC_NUMERIC=fi_FI.UTF-8
LC_TIME=fi_FI.UTF-8


#2

Hi there, sorry for the late reply.
Some commands, like setting locale, does not work on Manjaro ARM yet.

I still haven’t figured out why, but I think it’s related to polkit.
Because of this I actually pulled out Manjaro Settings Manager from the 18.12 (and forward) images.