Cannot satisfy dependencies for a system update

When I tried to install 700 updates, this is what I saw:

$ sudo /usr/lib/octopi/octphelper -ts
:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community is up to date
 multilib is up to date
:: Starting full system upgrade...
:: Replace jack with extra/jack2? [Y/n] Y
:: Replace lib32-jack with multilib/lib32-jack2? [Y/n] Y
:: Replace lib32-libcanberra-pulse with multilib/lib32-libcanberra? [Y/n] Y
:: Replace libcanberra-pulse with extra/libcanberra? [Y/n] Y
:: Replace pamac-common with extra/libpamac? [Y/n] Y
:: Replace qca with extra/qca-qt5? [Y/n] Y
resolving dependencies...
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: installing lib32-libcanberra (0.30+2+gc0620e4-5) breaks dependency 'lib32-libcanberra=0.30+2+gc0620e4-3' required by lib32-libcanberra-gstreamer
:: installing libcanberra (0.30+2+gc0620e4-5) breaks dependency 'libcanberra=0.30+2+gc0620e4-3' required by libcanberra-gstreamer

What should I do next? I’ve tried this a second time I’ve tried this install.

Remove lib32-libcanberra-gstreamer and libcanberra-gstreamer.

This has been covered in nearly every stable update post since libcanberra-gstreamer was deprecated.

Further to what @anon59284200 said. ALWAYS check the forum post about updating the Manjaro system you are using. This is from the ‘stable’ branch.

  • You might be blocked updating when using pacman due to some libcanberra packages. Simply remove those packages: sudo pacman -Rdd lib32-libcanberra-pulse lib32-libcanberra-gstreamer libcanberra-pulse libcanberra-gstreamer. We recommend to use pamac anyway, which does this automatically: pamac update

Check it out here.

Look under “Known issues and solutions”.

Like I said ALWAYS check the forum post about updates. That will keep you out of trouble.