Cannot run pwmconfig (There are no pwm-capable sensor modules installed)

Your fan sensor is not detected. Is your fan running as it should? Does your BIOS have any fan settings?

How do I find out? Should I look into the BIOS settings at startup?

Right, or you might be able to find the laptop manual online.

The fan is working, sometimes faster, sometimes slower. The thing is that it never stops, so I was wondering if I could do something about it.

This is the manual I’ve found online but there’s nothing about fan control. I’ll check in the BIOS at startup but I don’t recall having ever seen that information there.

1 Like

You might be able to get NBFC or amdgpu-fan to do what you want.

I’ve tried both, and both don’t work with weird errors. In NBFC, but my laptop isn’t listed, and I haven’t found a single laptop with AMD hardware (all Intel or NVidia). amdgpu-fan seems more promising, but it throws errors for which there is very little on the web. So I’m giving up for the moment, as the fan works decently even if the sensor is not recognized.

Thanks for your help anyway.

I’ll make a last attempt and hear if @cscs (who should have the same laptop as me) has experienced the same problem.

As far as I see there is no fan control support in the kernel for Huawei laptops, so fancontrol/pwmconfig won’t function. Unless you find an out-of-tree kernel module.

1 Like

If thats true I will just drop this here (please note it probably needs some work now)

  • main thing to note there is that some kernel options are not required if you use one of the raven kernels.

  • then see bottom for tlp and fan control and all that.
    (I am again not sure it is the current best option for this machine … but I havent had a need to change from using amdgpu-fancontrol)

1 Like

I have the same problem with my Lenovo Ideapad S340… I think our laptops are just not controllable in that regard idk. I have the exact same problems and sensors also shows me

k10temp-pci-00c3

and no pwm value, pwmconfig also does not work. Also no settings in the bios. It’s just a shame

1 Like

I stand corrected, the GPU fan seems to be indeed configurable via the hwmon interface. But I wonder, then, why isn’t it picked up by pwmconfig? Or why doesn’t it exist? Maybe the model is different?

(By the way, the “lm_sensors” link points to a non-existing file.)

I have the same APU. The the issues that warranted the following have long since been fixed:

iommu=pt idle=nomwait

There are a few others that also may not be required, but it depends on the BIOS.

I know your guide and I have followed it but, like others who have replied here, my fan sensor is not detected. You have the 2018 model if I’m correct, I bought it this year, so something in the hardware must have changed.

1 Like

anything new? still struggling with a really loud fan when charging my laptop… So annoying

I think it is beyond my expertise to fix this. I don’t know if it’s possible to do some hacking or we just have to wait until the kernel supports this hardware.

Yo its me again, I think this might be a problem with the zen+ architecture of ryzen? Because on my desktop, where I have a Ryzen 5 2600 installed (Same architecture as our laptop cpu, zen+) I also have no pwm output in sensors.
The name of the “device” on my pc is also

k10temp-pci-00c3

I dont know if it is the same with all the ryzen architectures or just a zen+ problem, but I think we have to contact amd to fix their drivers or whatever.
I really dont care on my desktop since I have a CPU watercooler installed and its really quiet, but my laptop fan gets really fricking loud when doing trivial tasks such as watching videos.
I also tought it might have been a systemd problem so I installed artix linux on my laptop with open-rc but it was not the problem… too bad that it is something out of our control :frowning:

Edit: I found out other cpu architectures also use the k10temp module, so I dont think its an architecture problem, just that the k10temp module does not have a pwm reading capability or however you would call it.

1 Like

Not supported. sensors-detect found nothing. Same Problem here.
Ryzen 5 3500

I just wonder if it will be supported in the future, or if I should sell this new laptop and just buy a used thinkpad or something…

Just tried them today (amdgpu-fancontrol, amdgpu-fan, nbfc), they don’t work in my machine
(AMD Ryzen 5 3500U with Vega GPU)