Cannot rename folder named `smb` in Windows as seen via SMB from Manjaro

I AM SORRY, but please ignore this question.

I just rebooted the computers, and the problem went away. I should have done that before posting.

If the post should be deleted, I will do that.

When I have to use files in a Windows computer while logged into Manjaro, I mount the Windows location (usually the whole partition) into a Manjaro folder or use Thunar with an address such as:


But today I found this interesting little problem of not being able rename a particular Windows location, which goes:


When I try, I am told “Permission denied.” When I retry, Thunar quits without a word. All that, when I could readily rename locations just above or below it e.g.


Again, I am unable to rename:

smb://username@host/partition/some/random/phrases/smb/- protocol

when I can rename

smb://username@host/partition/some/random/phrases/smb/android to windows

I did not do anything on the Windows side with permissions or sharing except to share the whole partition and give “full control” permissions to username. That is, I didn’t do anything to smb or - protocol.

How could I explain this selective inability? Is there something special to the two phrases that cannot be renamed?

Obviously, this is not life and death. I don’t have to rename those things but would like to understand what is up. Thanks.

I would also like to mention that all the colors and bold typeface (for partition, some, or to) in the quoted address are not my work.

Just a hunch, is the android directory empty while the smb is not?

Mount the network drive and you probably won’t have these problems.

Thanks for your hunch, but they both (and all the other locations I mention) have stuff in them. Little shortcuts I create on the topic by dragging from the Web browser address field into either Windows Explorer (which gives me a .url file) or into Thunar (a .desktop file).

Mounting does not make a difference. Unable to rename those two folders whether after mounting the partition or pointing to it as an smb:// address.

Ok - then you are defining a mount point e.g. /data/win/c

This is not how it works - but you can rename - then you need to take into account the target filesystem limitations - after all it is windows and the chars allowed on Linux may not be allowed on windows and you would need to use quotes to counteract the space in the filename.

mv "/data/win/c/some/random/phrases/smb/- protocol" "/data/win/c/some/random/phrases/smb/renamed-to"

Thanks. If I still had the problem, I would have tried mv.

But rebooting made it go away.

Why the problem existed even temporarily, I will never find out unless it recurs. I didn’t do anything special. I just put more stuff in the folder and wanted to rename it.

There is a windows option you can use at mounting that automatically changes characters that windows would not like but are ok in linux. IIRC.

I searched the interweb and my info seems to be inaccurate, please disregard.
Not sure how to do that fancy “overlining the text” I see other ppl doing here on the forum. xD