Cannot remove kernel linux 5.10

I tried to remove 5.10 kernel by opening “Manjaro Einstellungsmanager”, klicking on Kernel, klicking on Linux 5.10.124-1, then “entfernen” (remove).

5.10 is the oldest kernel installed. 5.18.6-1 is currently used.

The error messages are:

:: removing linux510 breaks dependency ‘linux510’ required by linux-latest
:: removing linux510-r8168 breaks dependency ‘linux510-r8168’ required by linux-latest-r8168

How can I repair this?

Remove the “latest” packages.

I cannot see any “latest” packages.

He meant the linux-latest* packages, such as those listed in the error message…

Had the same problem:

removing linux510 breaks dependency ‘linux510’ required by linux-latest
removing linux510-headers breaks dependency ‘linux510-headers’ required by linux-latest-headers

Solution as advised:

$ sudo pacman -R linux-latest linux-latest-headers

I cannot see any latest, linux-latest or *latest packages. Manjaro-settings-manager shows these installed kernels:

  • Linux 5.18.6-1
  • Linux 5.17.15-1
  • Linux 5.15.49-1 LTS
  • Linux 5.10.124-1 LTS

All I would like to do is to remove the oldest kernel.

Sorry, I overlooked this post. It worked to remove the linux-latest mentioned in the error message. Thank you.

you should remove 5.17.15

sudo mhwd-kernel -r linux517

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.