Cannot power on Bluetooth: Unexpected NULL btd_adv_monitor_manager object upon power down

bluetooth.service causes errors so that I cannot power on Bluetooth.

How to reproduce:

  1. Turn on the computer
  2. Power on Bluetooth with bluetoothctl power on, causing an error Failed to set mode: Authentication Failed (0x05) in systemctl status
  3. Restart bluetooth with sudo systemctl restart bluetooth, causing an error src/adv_monitor.c:btd_adv_monitor_power_down() Unexpected NULL btd_adv_monitor_manager object upon power down in systemctl status

What I tried before:

  1. sudo rfkill block bluetooth; sudo rfkill unblock bluetooth; sudo systemctl restart bluetooth.service does not work
  2. This article referring the same error message suggests downgrading bluez version to 5.61 but it does not work

System info:
Operating System: Manjaro Linux
KDE Plasma Version: 5.25.0
KDE Frameworks Version: 5.95.0
Qt Version: 5.15.5
Kernel Version: 5.18.5-1-MANJARO (64-bit)
Graphics Platform: X11
Processors: 12 × AMD Ryzen 5 3600 6-Core Processor
Memory: 31.3 GiB of RAM
Graphics Processor: NVIDIA GeForce GTX 1080/PCIe/SSE2

bluez Version: 5.64-2
bluez-libs Version: 5.64-2
bluez-qt Version: 5.95.0-1
bluez-utils Version: 5.64-2
pipewire Version: 1:0.3.52-2
pipewire-alsa Version: 1:0.3.52-2
pipewire-media-session Version: 1:0.4.1-2
pipewire-pulse 1:0.3.52-2
pipewire-zeroconf 1:0.3.52-2

I don’t know why but after some more reboots the problem is disappeared