Cannot Open Audacity

I’m not sure what has happened, but I can no longer launch Audacity. When I select the app from the whisker menu, nothing happens. So I tried running it from the terminal. Immediately, I get these errors:

(process:13076): Gdk-CRITICAL **: 13:44:58.239: gdk_screen_get_root_window: assertion 'GDK_IS_SCREEN (screen)' failed

(process:13076): Gdk-CRITICAL **: 13:44:58.240: gdk_window_get_display: assertion 'GDK_IS_WINDOW (window)' failed

(process:13076): Gdk-CRITICAL **: 13:44:58.240: gdk_cursor_new_from_pixbuf: assertion 'GDK_IS_DISPLAY (display)' failed

Here’s the deets from my installation:

  Host: OrangeKarat Kernel: 6.1.12-1-MANJARO arch: x86_64 bits: 64
    Desktop: Xfce v: 4.18.1 Distro: Manjaro Linux
  Type: Desktop Mobo: Micro-Star model: MPG X570 GAMING EDGE WIFI (MS-7C37)
    v: 1.0 serial: <superuser required> UEFI: American Megatrends LLC. v: 1.J0
    date: 09/01/2022
  Info: 12-core model: AMD Ryzen 9 3900X bits: 64 type: MT MCP cache:
    L2: 6 MiB
  Speed (MHz): avg: 2380 min/max: 2200/4672 cores: 1: 2200 2: 2200 3: 2616
    4: 2200 5: 1892 6: 2200 7: 2800 8: 3800 9: 2200 10: 2200 11: 2200 12: 2200
    13: 2198 14: 2200 15: 2200 16: 2200 17: 2200 18: 2800 19: 2425 20: 2200
    21: 2200 22: 2800 23: 2200 24: 2800
  Device-1: AMD Navi 10 [Radeon RX 5600 OEM/5600 XT / 5700/5700 XT]
    driver: amdgpu v: kernel
  Device-2: Logitech HD Pro Webcam C920 type: USB
    driver: snd-usb-audio,uvcvideo
  Display: x11 server: X.Org v: 21.1.7 driver: X: loaded: amdgpu
    unloaded: modesetting,radeon dri: radeonsi gpu: amdgpu
    resolution: 3840x2160~60Hz
  API: OpenGL Message: Unable to show GL data. Required tool glxinfo
  Device-1: AMD Navi 10 HDMI Audio driver: snd_hda_intel
  Device-2: AMD Starship/Matisse HD Audio driver: snd_hda_intel
  Device-3: Logitech HD Pro Webcam C920 type: USB
    driver: snd-usb-audio,uvcvideo
  Device-4: Medeli USB Audio Device type: USB
    driver: hid-generic,snd-usb-audio,usbhid
  Sound API: ALSA v: k6.1.12-1-MANJARO running: yes
  Sound Server-1: PulseAudio v: 16.1 running: yes
  Sound Server-2: PipeWire v: 0.3.65 running: yes
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    driver: r8169
  IF: enp39s0 state: down mac: 2c:f0:5d:81:d1:4f
  Device-2: Intel Dual Band Wireless-AC 3168NGW [Stone Peak] driver: iwlwifi
  IF: wlp41s0 state: up mac: 34:7d:f6:fb:b9:a9
  Device-1: Intel Wireless-AC 3168 Bluetooth type: USB driver: btusb
  Report: rfkill ID: hci0 state: up address: see --recommends
  Local Storage: total: 931.51 GiB used: 493.42 GiB (53.0%)
  ID-1: /dev/nvme0n1 vendor: Sabrent model: Rocket Q size: 931.51 GiB
  ID-1: / size: 915.52 GiB used: 493.42 GiB (53.9%) fs: ext4 dev: /dev/dm-0
  ID-2: /boot/efi size: 299.4 MiB used: 476 KiB (0.2%) fs: vfat
    dev: /dev/nvme0n1p1
  Alert: No swap data was found.
  System Temperatures: cpu: 42.9 C mobo: N/A gpu: amdgpu temp: 46.0 C
  Fan Speeds (RPM): N/A gpu: amdgpu fan: 0
  Processes: 457 Uptime: 15h 35m Memory: 62.72 GiB used: 4.63 GiB (7.4%)
  Shell: Bash inxi: 3.3.25

Has anyone else run into a similar problem? I’m at a loss.

The audacity appimage from their(Audacity) website works fine here.

Alas, I get the same error whether by installing via the manjaro repo, flatpak, and Audacity’s own AppImage.

Looks like there are some related issues on the Audacity GitHub, but from my understanding it doesn’t cause failures to launch for others.

I actually get the same errors, but Audacity still launches fine for me.

Your failure to launch is probably unrelated to these errors.

I also get those errors but it still launches and seems to work as intended.

This is a shot in the dark, but since the issue spans across native, flatpak, and appimage packages, perhaps it has to do with some bad/corrupt configuration in ~/.audacity-data.

Maybe try mv ~/.audacity-data ~/.audacity-data.bak and launching again so you start with a fresh config? This will move your audacity user data to a different folder so Audacity begins with a clean config. If still doesn’t launch just delete the directory it creates (if it makes a fresh one) and put the backup back.


You will see those and similar errors while opening a graphical app in the terminal. Usually caused by version mismatches. If a library updates but the package that depends on it doesn’t then you have a mismatch. If the app is rebuilt on the new lib the errors usually go away. This is just one example.

I haven’t used it in awhile, but I got a message about incompatible plugins,
Rubber Band R3 Stereo Pitch Shifter
Rubber Band Mono Pitch Shifter
that are now disabled. I’m using the version from the repository. Seems to function otherwise, what little testing I did.

Audacity configuration folder was changed when v3.2.0 released Sep 2022

Release Audacity 3.2.0 · audacity/audacity · GitHub

Audacity now uses XDG directories on Linux.

Note: If you are upgrading from a previous version, Audacity will keep using the ~/.audacity-data and ~/.audacity folders until you delete them.

Legacy configuration folder ~/.audacity-data/ should be removed so Audacity can create a new configuration folder ~/.config/audacity/

But Audacity still has the same 3 errors if launched from terminal and still takes a long time to launch main window

I use ocenaudio AUR more than Audacity nowadays:

  • Starts quick and error-free;
  • Load/save audio content faster than Audacity can import/export;
  • Works with all Linux sound servers and does not need PortAudio API