Cannot make F13-F20 keys functional

I have a DELL G5 5500 laptop, which has a G-mode key and a Keyboard Backlight control key.
In case anyone is curious what do the keys look like:
https://paste dot pics/6668b0a5d0ce1453c73bbf98290b271f
On Windows, pressing Fn+F7 would get F17, and Fn+F10 would get F18.
However when I switched to Manjaro, these two function keys become not usable.
I mean, I cannot use the keys for shortcuts in Manjaro settings, and I tried running xev in Konsole, but it simply output nothing when I pressed Fn+F7 and Fn+F10, while all other function keys remained functional.
I tried to write a .Xmodmap file like this and put it in ~/ :

cat .Xmodmap
keycode 191 = F13 F13 F13
keycode 192 = F14 F14 F14
keycode 193 = F15 F15 F15
keycode 194 = F16 F16 F16
keycode 195 = F17 F17 F17
keycode 196 = F18 F18 F18
keycode 197 = F19 F19 F19
keycode 198 = F20 F20 F20
keycode 199 = F21 F21 F21
keycode 200 = F22 F22 F22
keycode 202 = F23 F23 F23
keycode 203 = F24 F24 F24

But it is of no use.

How can I use the two “non-exist” keys?

My setup info is as follows:

  Kernel: 6.1.21-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.2.1
    parameters: BOOT_IMAGE=/boot/vmlinuz-6.1-x86_64
    root=UUID=6c8ede06-c88d-4697-8fe7-5aae0f6ef8cc rw quiet splash
    udev.log_priority=3 resume=UUID=b5e102d2-0d35-480b-a46e-2296c5389a3a
  Desktop: KDE Plasma v: 5.27.3 tk: Qt v: 5.15.8 info: latte-dock
    wm: kwin_x11 vt: 1 dm: SDDM Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: Dell product: G5 5500 v: N/A
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: Dell model: 039Y47 v: A03 serial: <superuser required> UEFI: Dell
    v: 1.21.0 date: 11/10/2022
  ID-1: BAT0 charge: 44.0 Wh (100.0%) condition: 44.0/68.0 Wh (64.8%)
    volts: 16.5 min: 15.2 model: LGC-LGC4.474 DELL JJRRD06 type: Li-poly
    serial: <filter> status: full
  RAM: total: 15.39 GiB used: 5.57 GiB (36.2%)
  RAM Report: permissions: Unable to run dmidecode. Root privileges required.
  Info: model: Intel Core i7-10750H bits: 64 type: MT MCP arch: Comet Lake
    gen: core 10 level: v3 note: check built: 2020 process: Intel 14nm family: 6
    model-id: 0xA5 (165) stepping: 2 microcode: 0xF4
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
    L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 1.5 MiB desc: 6x256 KiB
    L3: 12 MiB desc: 1x12 MiB
  Speed (MHz): avg: 2316 high: 2600 min/max: 800/5000 scaling:
    driver: intel_pstate governor: powersave cores: 1: 2600 2: 2600 3: 2600
    4: 2600 5: 2600 6: 900 7: 2600 8: 2600 9: 2600 10: 2600 11: 900 12: 2600
    bogomips: 62431
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat
    arch_capabilities arch_perfmon art avx avx2 bmi1 bmi2 bts clflush
    clflushopt cmov constant_tsc cpuid cpuid_fault cx16 cx8 de ds_cpl dtes64
    dtherm dts epb ept ept_ad erms est f16c flexpriority flush_l1d fma fpu
    fsgsbase fxsr ht hwp hwp_act_window hwp_epp hwp_notify ibpb ibrs
    ibrs_enhanced ida intel_pt invpcid invpcid_single lahf_lm lm mca mce
    md_clear mmx monitor movbe mpx msr mtrr nonstop_tsc nopl nx ospke pae pat
    pbe pcid pclmulqdq pdcm pdpe1gb pebs pge pku pln pni popcnt pse pse36 pts
    rdrand rdseed rdtscp rep_good sdbg sep smap smep ss ssbd sse sse2 sse4_1
    sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc tsc_adjust
    tsc_deadline_timer vme vmx vnmi vpid x2apic xgetbv1 xsave xsavec xsaveopt
    xsaves xtopology xtpr
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data mitigation: Clear CPU buffers; SMT vulnerable
  Type: retbleed mitigation: Enhanced IBRS
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB
    filling, PBRSB-eIBRS: SW sequence
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
  Device-1: Intel CometLake-H GT2 [UHD Graphics] vendor: Dell driver: i915
    v: kernel arch: Gen-9.5 process: Intel 14nm built: 2016-20 ports:
    active: eDP-1 empty: DP-1, DP-2, HDMI-A-1, HDMI-A-2 bus-ID: 00:02.0
    chip-ID: 8086:9bc4 class-ID: 0300
  Device-2: NVIDIA TU106M [GeForce RTX 2060 Mobile] vendor: Dell
    driver: nvidia v: 530.41.03 alternate: nouveau,nvidia_drm non-free: 530.xx+
    status: current (as of 2023-03) arch: Turing code: TUxxx
    process: TSMC 12nm FF built: 2018-22 pcie: gen: 3 speed: 8 GT/s lanes: 8
    link-max: lanes: 16 bus-ID: 01:00.0 chip-ID: 10de:1f15 class-ID: 0300
  Device-3: Realtek Integrated_Webcam_HD type: USB driver: uvcvideo
    bus-ID: 1-5:5 chip-ID: 0bda:5678 class-ID: 0e02 serial: <filter>
  Display: x11 server: X.Org v: 21.1.8 compositor: kwin_x11 driver: X:
    loaded: modesetting,nvidia alternate: fbdev,nouveau,nv,vesa dri: iris
    gpu: i915 display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
    s-diag: 582mm (22.93")
  Monitor-1: eDP-1 model: AU Optronics 0x80ed built: 2018 res: 1920x1080
    hz: 144 dpi: 142 gamma: 1.2 size: 344x194mm (13.54x7.64") diag: 395mm (15.5")
    ratio: 16:9 modes: 1920x1080
  API: OpenGL v: 4.6 Mesa 23.0.1 renderer: Mesa Intel UHD Graphics (CML GT2)
    direct-render: Yes
  Device-1: Intel Comet Lake PCH cAVS vendor: Dell
    driver: sof-audio-pci-intel-cnl alternate: snd_hda_intel, snd_soc_skl,
    snd_sof_pci_intel_cnl bus-ID: 00:1f.3 chip-ID: 8086:06c8 class-ID: 0401
  Device-2: NVIDIA TU106 High Definition Audio vendor: Dell
    driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 8 link-max:
    lanes: 16 bus-ID: 01:00.1 chip-ID: 10de:10f9 class-ID: 0403
  API: ALSA v: k6.1.21-1-MANJARO status: kernel-api with: aoss
    type: oss-emulator tools: alsamixer,amixer
  Server-1: sndiod v: N/A status: off tools: aucat,midicat,sndioctl
  Server-2: JACK v: 1.9.22 status: off tools: N/A
  Server-3: PipeWire v: 0.3.67 status: off with: wireplumber status: active
    tools: pw-cli,wpctl
  Server-4: PulseAudio v: 16.1 status: active tools: pacat,pactl
  Device-1: Intel Comet Lake PCH CNVi WiFi vendor: Rivet Networks
    driver: iwlwifi v: kernel bus-ID: 00:14.3 chip-ID: 8086:06f0 class-ID: 0280
  IF: wlp0s20f3 state: up mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: noprefixroute scope: link
  Device-2: Realtek vendor: Dell driver: r8169 v: kernel pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 port: 3000 bus-ID: 3c:00.0 chip-ID: 10ec:2502
    class-ID: 0200
  IF: enp60s0 state: down mac: <filter>
  WAN IP: <filter>
  Device-1: Intel AX201 Bluetooth type: USB driver: btusb v: 0.8 bus-ID: 1-14:8
    chip-ID: 8087:0026 class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 0 state: up address: see --recommends
  Message: No logical block device data found.
  Message: No RAID data found.
  Local Storage: total: 1.04 TiB used: 374.01 GiB (35.2%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: KIOXIA model: EXCERIA SSD
    size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
    lanes: 4 type: SSD serial: <filter> rev: ECFA15.3 temp: 38.9 C scheme: GPT
  ID-2: /dev/nvme1n1 maj-min: 259:4 vendor: Toshiba model: KBG40ZNS512G NVMe
    KIOXIA 512GB size: 476.94 GiB block-size: physical: 512 B logical: 512 B
    speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: 10410106
    temp: 39.9 C scheme: GPT
  ID-3: /dev/sda maj-min: 8:0 type: USB vendor: Generic model: SD MMC MS PRO
    size: 119.38 GiB block-size: physical: 512 B logical: 512 B type: SSD
    serial: <filter> rev: 1.00 scheme: MBR
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
  Message: No optical or floppy data found.
  ID-1: / raw-size: 200 GiB size: 195.8 GiB (97.90%) used: 112.07 GiB (57.2%)
    fs: ext4 dev: /dev/nvme1n1p6 maj-min: 259:10 label: N/A
    uuid: 6c8ede06-c88d-4697-8fe7-5aae0f6ef8cc
  ID-2: /boot/efi raw-size: 450 MiB size: 446.5 MiB (99.22%)
    used: 59.5 MiB (13.3%) fs: vfat dev: /dev/nvme1n1p1 maj-min: 259:5 label: N/A
    uuid: B819-326E
  ID-3: /run/media/charles/DELL raw-size: 334.43 GiB
    size: 334.43 GiB (100.00%) used: 137.51 GiB (41.1%) fs: ntfs
    dev: /dev/nvme0n1p1 maj-min: 259:1 label: DELL uuid: 547B04164934C3CB
  ID-4: /run/media/charles/Windows raw-size: 224.36 GiB
    size: 224.36 GiB (100.00%) used: 124.37 GiB (55.4%) fs: ntfs
    dev: /dev/nvme1n1p3 maj-min: 259:7 label: Windows uuid: D2887DDA887DBD93
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 20 GiB used: 0 KiB (0.0%) priority: -2
    dev: /dev/nvme0n1p3 maj-min: 259:3 label: Swap
    uuid: b5e102d2-0d35-480b-a46e-2296c5389a3a
  ID-1: /dev/nvme0n1p2 maj-min: 259:2 size: 111.33 GiB fs: ext4
    label: Timeshift uuid: 84361946-780a-4940-aa97-ebe037b74ee4
  ID-2: /dev/nvme1n1p2 maj-min: 259:6 size: 16 MiB fs: <superuser required>
    label: N/A uuid: N/A
  ID-3: /dev/nvme1n1p4 maj-min: 259:8 size: 1.06 GiB fs: ntfs label: N/A
    uuid: 7028FE1628FDDB54
  ID-4: /dev/nvme1n1p5 maj-min: 259:9 size: 50 GiB fs: ntfs label: VM
    uuid: 32786C2E1EC23210
  ID-5: /dev/nvme1n1p7 maj-min: 259:11 size: 1.06 GiB fs: ntfs
  ID-6: /dev/sda1 maj-min: 8:1 size: 119.36 GiB fs: exfat label: Samsung-RP
    uuid: A8E0-06AF
  Hub-1: 1-0:1 info: Hi-speed hub with single TT ports: 16 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Hub-2: 1-1:2 info: Genesys Logic Hub ports: 4 rev: 2.1 speed: 480 Mb/s
    power: 100mA chip-ID: 05e3:0610 class-ID: 0900
  Device-1: 1-2:3 info: Shenzhen Rapoo 2.4G Wireless Device
    type: Mouse,Keyboard driver: hid-generic,usbhid interfaces: 3 rev: 2.0
    speed: 12 Mb/s power: 100mA chip-ID: 24ae:2010 class-ID: 0301
  Device-2: 1-3:4 info: Logitech Logi Bolt Receiver type: Keyboard,Mouse,HID
    driver: hid-generic,usbhid interfaces: 3 rev: 2.0 speed: 12 Mb/s power: 98mA
    chip-ID: 046d:c548 class-ID: 0300
  Device-3: 1-5:5 info: Realtek Integrated_Webcam_HD type: Video
    driver: uvcvideo interfaces: 2 rev: 2.0 speed: 480 Mb/s power: 500mA
    chip-ID: 0bda:5678 class-ID: 0e02 serial: <filter>
  Device-4: 1-6:6 info: Realtek USB2.0-CRW type: Mass Storage
    driver: ums-realtek interfaces: 1 rev: 2.0 speed: 480 Mb/s power: 500mA
    chip-ID: 0bda:0177 class-ID: 0806 serial: <filter>
  Device-5: 1-11:7 info: Alienware LED controller type: HID
    driver: hid-generic,usbhid interfaces: 1 rev: 2.1 speed: 12 Mb/s
    chip-ID: 187c:0550 class-ID: 0300 serial: <filter>
  Device-6: 1-14:8 info: Intel AX201 Bluetooth type: Bluetooth driver: btusb
    interfaces: 2 rev: 2.0 speed: 12 Mb/s power: 100mA chip-ID: 8087:0026
    class-ID: e001
  Hub-3: 2-0:1 info: Super-speed hub ports: 8 rev: 3.1 speed: 10 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  Hub-4: 2-1:2 info: Genesys Logic Hub ports: 4 rev: 3.2 speed: 5 Gb/s
    chip-ID: 05e3:0626 class-ID: 0900
  Hub-5: 5-0:1 info: Hi-speed hub with single TT ports: 2 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Hub-6: 6-0:1 info: Super-speed hub ports: 2 rev: 3.1 speed: 10 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  System Temperatures: cpu: 50.0 C pch: 49.0 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 333 Uptime: 1h 31m wakeups: 5706 Init: systemd v: 252
  default: graphical tool: systemctl Compilers: gcc: 12.2.1 clang: 15.0.7
  Packages: 1498 pm: pacman pkgs: 1488 libs: 399 tools: pamac,yay pm: flatpak
  pkgs: 10 Shell: Zsh v: 5.9 default: Bash v: 5.1.16 running-in: konsole
  inxi: 3.3.26

P.S.:I’m not a native English speaker and this is the first time I post on this forum. Please pardon me for any inappropriate expressions. Thanks for anyone who spare their time to offer some help.

Then the keypress for intent and purpose doesn’t exist - the hardware isn’t informing the kernel of the keypress.

This leads me to think you are missing a driver or interface to these specific keys.

If I were you I would go searching for a patch or a kernel module …

I did a search for you

Wow. That sounds not so great for a Linux newbie like me.
Would you please make further explanations?

======Text above was written 6days ago======

Thank you.
I did a lot of background search too, only to find certain G5 5500 machines were sold with Ubuntu installed… And in the Ubuntu hardware information page I found nothing useful.
It said Keyboard AT Translated Set 2 keyboard
And I can not find any model similar in Manjaro keyboard setting panel. Frankly, if there was one, I do not expect simply selecting it would make magic.

I regret to say that nothing in your link seems to work either. I went through 3 pages and hit every answer which I think the key might lie in, but they didn’t make sense. Even Arch Wiki has no solution to my problem.

That’s pretty ‘normal’. I mean, the notebook’s 3 years old and it’s not really popular even back in 2020.

The two unusable keys are only a little flaw, which can be easily outweighed by the overall usability. Unlike my previous Ubuntu installation, all other components of this notebook run really smooth on Manjaro. I have nothing more to complain about.

I do not expect this to be solved in weeks or even months. However I will keep this post open (before it’s forced to close due to inactivity, sadly) and all potential solutions are welcomed. And if I am lucky enough (not likely) to run into an unexpected solution, I will post it here to help those who share a similar model with me.

P.S.: I actually wanted to write a patch on my own but I did not know how to… And unfortunately I don’t have enough time to dive into those expatiatory manuals.