Cannot log into kde

I accidentally clicked sleep on RAM in the start menu one hour ago.

I’ve tried everything, but I get this weird log in screen (different from the normal one). I can type in my password, but when I press enter nothing happens.

Please help…

did you rebooted?

Multiple times

so enter in the screen into tty - ctrl+alt+f2 - or f1-f6 keys, log in and type startx

I’ve already tried it, but it says couldn’t exec startplasma-x11 (no such file or directory).

I am trying to install the new kernel. I hope this will help.

Didn’t work

and if you reinstall xorg:
sudo pacman -S xorg-server
systemctl reboot

edit: reinstall also sddm:
sudo pamac -S sddm

The same error after no such file or directory

and this:
sudo pacman -S xorg-xinit
and did you reinstall also sddm?

Doesn’t work and yes.

Maybe I should just copy my files to a hard drive, but I can’t find it.

what do you mean copy?
check logs:
journalctl -b0 -p5 --no-pager

I can still access my files.

What should I look for.

look for logs related to sddm/x11/xorg, if there is something

There are only sddm errors. The first being could not set up default cursor, then something about my theme.

and run this:
kbuildsycoca5 --noincremental

Kbuildsyscoca5 is not found

something got really messed up there… and it doesnt make sense that it was caused just by putting your system to sleep…
sudo pacman -Syyu
any errors from this command?