Cannot load images or the Twitch blog

This is a weird issue that’s affecting several browsers, with the exception of Librewolf, which loads everything on Twitch just fine. On everything else I’ve tried; Firefox, ungoogled-chromium, Vivaldi, with each being a fresh install and going straight to Twitch (so no extensions installed, and no settings changed), no avatars or thumbnails load. Trying to load the images in a separate tab gives an immediate “Server not found” error like it’s being actively blocked, and this also affects the Twitch blog site. I find it strange, though, that Librewolf isn’t affected, like there’s some common setting in all the other browsers preventing Twitch from loading properly.

Could be a DNS issue. Perhaps Librewolf (not familiar with it) is bypassing the DNS server configured on your router?

For example, can you ping this address from a terminal?


1 Like

In Firefox go to the bottom of config page and in Network settings enable the DNS over HTTPS and select a DNS server there. Try then.


Good idea. It’s been long since I’ve used Firefox from scratch. Does it leave this option disabled by default on new installations?

I think it should be enabled by default but I’m not sure.

Did some tweaking there, enabling either “Proxy DNS when using SOCKS v5” OR “DNS over HTTPS” fixes it. Tried looking in Chromium for similar settings, but can’t find them. Thinking my ISP’s DNS servers are being weird, because pinging that address results in a “Name or service not known”.

Thanks for the help so far, if anyone knows the Chromium equivalent of those settings, feel free to tell me, I’ll be looking myself for them in the meantime.

You can also set DNS system wide in the Network configuration, use and for DNS servers (Cloudflare).
Set the network IPV4 protocol to Automatic (address only) and set the DNS servers there. Save, reboot (or restart the network service I guess, but reboot is to make sure it is applied).


Yeah, changing the DNS servers on my router will likely be the best bet, so all my stuff goes through them. Thanks a bunch for the help! :slight_smile:

Based on what you’ve told us, it’s likely that Librefox ships out-of-the-box with DoH enabled (and thus using a compatible upstream DNS server, bypassing your router’s settings). Hence, why enabling DoH on Firefox per @omano’s suggestion yielded the same (correct) results of properly loading images from the CDN.

Ironically, the situation is completely reversed for me. :wink: I’m using a third-party firmware flashed router (FreshTomato open source firmware), and I have it set to use Cloudflare’s DNS servers, and to intercept all DNS requests from devices on the network, and force them to use the same Cloudfare DNS server. (In other words, if there’s a phone or computer manually configured to use Google’s DNS server of, my router intercepts it and sends the request to Cloudflare instead.)

  • Caveat, it can only intercept requests using port 53. It cannot intercept if the phone, computer, software, etc, is configured to use DNS-over-HTTPS/TLS, since they are encrypted in of themselves.

Actually, Librewolf had “Proxy DNS when using SOCKS v5” enabled. With it disabled, for some strange reason, only Twitch CDN and blog couldn’t get resolution, everything else on the internet loaded fine. Switching to Cloudflare DNS solved everything.

Also, nice to see another FreshTomato use :smiley:

Because it freaking rocks! :tomato: :love_you_gesture:

I misread your earlier post. For some reason I read that as your “ISP’s router”, and didn’t realize that you were using your ISP’s default DNS server via the default WAN options (on whatever router/firmware you happen to use.)

If you’re using the latest FreshTomato, you can even switch to Stubby resolvers exclusively.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.