Cannot Install TP-Link T2U Nano USB Wi-Fi Driver

Hi. I’m having issues with installing the TP-Link rtl8812au (T2U Nano) driver on Manjaro. I’ve previously installed this specific driver without any issue (2.4GHz & 5GHz bands both worked properly) on Ubuntu 22.04 and Pop!_OS 22.04. However, in Manjaro the same installation process from does not work.

Please help, Thanks!

Steps to Reproduce

sudo pacman -S extra/dkms extra/git

git clone <>

cd rtl8812au

#install method 1
sudo make dkms_install

#install method 2
sudo make && sudo make install

Here’s my system information

~/rtl8812au (v5.6.4.2 ✔) uname -r

~/rtl8812au (v5.6.4.2 ✔) cat /etc/os-release
NAME="Manjaro Linux"
PRETTY_NAME="Manjaro Linux"

Here’s the output from sudo make dkms_install

mkdir: created directory '/usr/src/8812au-'
cp -r * /usr/src/8812au-
dkms add -m 8812au -v
Creating symlink /var/lib/dkms/8812au/ -> /usr/src/8812au-
dkms build -m 8812au -v
Sign command: /usr/lib/modules/5.15.65-1-MANJARO/build/scripts/sign-file
Signing key: /var/lib/dkms/mok.key
Public certificate (MOK): /var/lib/dkms/
Binary sign-file not found, module won't be signed
Error! Your kernel headers for kernel 5.15.65-1-MANJARO cannot be found at /usr/lib/modules/5.15.65-1-MANJARO/build or /usr/lib/modules/5.15.65-1-MANJARO/source.
Please install the linux-headers-5.15.65-1-MANJARO package or use the --kernelsourcedir option to tell DKMS where it's located.
make: *** [Makefile:2317: dkms_install] Error 1

Here’s the output from sudo make && sudo make install

make ARCH=x86_64 CROSS_COMPILE= -C /lib/modules/5.15.65-1-MANJARO/build M=/home/manjaro_os/rtl8812au  modules
make[1]: *** /lib/modules/5.15.65-1-MANJARO/build: No such file or directory.  Stop.
make: *** [Makefile:2257: modules] Error 2
install -p -m 644 88XXau.ko  /lib/modules/5.15.65-1-MANJARO/kernel/drivers/net/wireless/
install: cannot stat '88XXau.ko': No such file or directory
make: *** [Makefile:2266: install] Error 1
pamac install linux515-headers

It worked. Thanks! Appreciate the help.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.