Cannot install mullvad vpn

I’ve just switched to manjaro and I’m experiencing problems with installing mullvad
I get failed to build and mullvadvpn-app-binaries git repo … FAILED (unknown public key 78CEAA8CB72E4467)
==> ERROR: One or more PGP signatures could not be verified!

I’ve followed the guide in Verifying signatures - Guides | Mullvad VPN
but I’m stuck at Verify the Mullvad VPN app where i get
gpg: verify signatures failed: Unexpected error

I have mullvad VPN and for me following their guide worked. Try mullvad-vpn-bin package in the AUR.

If you type the command gpg --list-keys do you see the mullvad key in the list?

pub rsa2048 2014-05-06 [SC] [expired: 2019-04-18]
uid [ expired] Tom Stellard

ok I tried again adding the key and it worked… must have missed a step

open a terminal and type:

gpg2 --keyserver --recv-keys A1198702FC3E0A09A9AE5B75D5A1D4F266DE8DDF

Then open the key edit prompt:

gpg2 --edit-key A1198702FC3E0A09A9AE5B75D5A1D4F266DE8DDF

Now type:


Set the trust level to 5 then type q to quit and hit enter

That’s good. Now you should be able to install mullvad without the verification error.

I think I found out what was wrong: yesterday I had a opendns server that wouldn’t allow mullvad’s website, I changed dns with google

A post was split to a new topic: Trouble with Mullvad VPN GPG verification