Cannot install dia diagram editor (again)

After running sudo pacman-mirrors --continent I’m not able to install dia diagram editor.

  yay -S dia-git
 -> No AUR package found for glib2-devel
 -> could not find all required packages: glib2-devel 

I could install it about two weeks ago ( Cannot install dia (diagram editor) - #13 by nagylzs ) but I think glib2-devel was renamed to glib2 recently, and this broke my system update scripts. I could not do yay -Sua anymore, because dia-git was installed and I always got this could not find all required packages: glib2-devel error message. So I removed git-dia and tried to install again. But it still fails, and now I don’t have a working dia. :frowning:

How can I install git-dia? Is it a dependency problem? Would it be possible to fix the deps somehow?

Thank you

yes is not in stable (aur is sync with arch)

Rather; glib2-devel was split out from glib2.

Either edit the PKGBUILD and remove glib2-devel or switch to the testing branch.

Remember, the AUR is neither officially supported by Arch nor Manjaro. When one uses the AUR, one must take responsibility for maintenance of said packages.


Until glib2-devel hit the repo you can build by passing -d (ignore depends) option to makepkg; note that you need the depends installed, this time for this pkgbuild is only a temporary naming thing

How can I edit PKGBUILD please? I could find out that the PKGBUILD file can be downloaded with:

yay -G dia-git

it gives no error, but I do not see the file anywhere. The yay documentation is not very helpful.

Oh I see now:

yay -G dia-git
cd dia-git
makepkg -si

makepkg -si fails with “could not install missing dependencies” libemf, xpm-pixbuf-git

After installing yay xpm-pixbuf-git manually, makepkg -si worked.

Thank you!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.