Cannot import a opvn file

What I’m trying to do, is to use NM to run my VPN configuration, instead of doing

sudo openvpn [configuration_file.opvn]

I do that by using the nm-applet:

Network-Manager > Edit Connections … > Add > [type] “Import a saved VPN configuration”

When I select a file with the .opvn extension, the dialog boxes simply dissappear, and nothing happens. NM/nm-applet itself does not crash, but the “Edit connections …” windows do. using xfce

Quite awhile back when I was usinig openVPN, network manager did not like how the .ovpn files were named. Try to rename the .ovpn file and import. In my case. it worked with the following format: .udp.ovpn

NM did not like the underscores in the provider’s configuration files.

Thank you but I have no underscores in the name. It worked great until a few days ago when I updated manjaro itself and now the dialog window just completely disappears after I click on the file to import. Never ever had this happen before and trying to find answer without reinstalling. I can import via cli and then edit with password etc so I can get the vpn up and running but prefer gui and it should just work

I did fresh install and problem persists. Maybe a bug and I dont know where or details needed to create a bug report

It is likely some issue with the configuration file itself. Network Manager is the same version across all branches, however, nm-connection-editor may be at fault. It looks as follows:
stable1.32.0-1 testing1.32.0-2 unstable1.32.0-2
I am on Unstable branch and was able to load an .ovpn file here:


How are you using the keys? They are usually as separate files, but it is possible to embed them.

When you are doing sudo openvpn <config>, that’s obviously root access. Are the keys hard coded paths or relative? Either way, NetworkManager needs the current user to be able to read these keys.

NetworkManager handles common configurations, but does make assumptions or mess up on valid configurations that work fine in OpenVPN via command line. I would start making a new configuration in NetowrkManager and then as the last step, take the lines out of the config file you absolutely need that you can’t do in the GUI.