Cannot grab Kernel 5.2

Hi all,
In preparation of the pending upgrade, I need to install an other kernel, since my current one (4.19) may not boot. MAY…since I use systemd 247.7-1…but, best be safe than sorry…
I tried to grab the recommened one : 5.20 but both mirrors I tried failed with a 404.
I have rebuilt the mirrorlist to include all but china, still it fails…

Hi @ButterflyMelissa,

Kernel 5.2 is nor longer available:

$ mhwd-kernel --list
available kernels:
* linux414
* linux419
* linux44
* linux49
* linux510
* linux511
* linux512
* linux513
* linux54
* linux510-rt
* linux511-rt

You asked for ideas and I have a strong suspicion that you meant version 5.4, which is available.


It can be installed using:

sudo mhwd-kernel --install linux54

Thanks for the reply. Well, at least I have a fresh mirror list now :rofl:
Retry somewhere today
:rose: Melissa :rose:

You’re very welcome!

Perhaps, maybe, posssibly give consideration to version 5.10. It is the latest LTS after all…

1 Like

:scream: I made a goofup! I meant to say that the 5.1 was not available instead of the 5.2!
Typo alert!
Let me select one of the others then.
:sob: so sorry to have mislead you…

Well, my answer still applies 100%, so no harm done whatsoever.

1 Like

Umm, I’m using the tool inthe GUI, not what I usually do. And it cannot find any kernel anywhere.
Let me try in the console instead…
edit - tap me on the head…I had to refresh the repo’s… :scream: all is well now…

I’d say that’s a good idea, yes. I only used the GUI the first 2/3 times, and only because I didn’t know the commands yet. Yeah, it was when I was still very new to Manjaro.

That would explain it, yeah. But I’m very glad all is well now.

1 Like

then for mirrors

sudo pacman-mirrors -c all 
sudo pacman -Syyu

after you can see for mhwd-kernel

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.