Cannot get Brother MFC-7440N to work at all

at first i simply added the printer using gui and all the default settings, but when attempting to print nothing would happen… so i tried to print a test page, which made my printer just spit out blank sheet after blank sheet until it was out of paper. So yeah, the default definitely doesn’t work. So then I sourced a printer specific ppd file to use, that just prevented the printer from doing anything.

i’ve installed the AUR packages brother-mfc7440n-lpr-bin and brother-mfc7440n-cups-bin using trizen, and then tried adding the printer in CUPS but that did not work either, printer not working with CUPS default or when i tried the ppd file.

not sure where to go from here troubleshooting, i just really need my printer to work (even if the scanning function does not).

what do?


Have you tried accessing CUPS interface through your browser?

In browser: localhost:631
Administration Tab- Add Printer or Manage Printer
Manage Printer Tab and the Printers Tab should show whether you have a printer installed. If it doesn’t show, try Add Printer

Make sure that CUPS is enabled:
systemctl enable --now cups.service
systemctl enable --now cups.socket
systemctl enable --now cups.path

Yes i did try accessing the interface through the browser. I was able to add the printer but with generic drivers whenever i try to print something it just floods paper out the front of the printer. I also tried it through the browser with the ppd file.

when i go to the openprinting website it does say that this printer is supported so idk whats happening

I have a similar printer. You could try to download the brother drivers from their website, and install locally. I noticed the aur seems to have some drivers that might fit you need. Works ok for me.