Cannot finish boot: encryption passphrase entered, "slot 0 opened", progress dots move, and then nothing changes

As of just today, I cannot finish booting. Here’s what happens:

    1. expected: I enter my disk encryption passphrase
    1. expected: I see “slot 0 opened”
    1. expected: said text disappears and I see the usual horizontal progress dots animating
    1. unexpected: then nothing changes. I’ve waited 5-20 min across three attempts now. When I finally give up the animation is eventually apparently frozen.

I’m not sure what to try. Does anyone have any ideas?

tl;dr to the future person stuck on boot sequence (after encryption password enters successfully): hit esc key (or really any keys) to see if you can get the animation to go away and reveal a hidden tty waiting for you.

I figured this out. The Manjaro boot sequence I mentioned being stuck was just hiding a fsck error. I figured this out by simply tapping wildly at random keys on my keyboard, in a desperate and unguided guess, until I lucked upon esc. Hitting esc toggled on and off said splash screen vs the rootfs shell where I had a detailed error message about a particular mount (a long /dev/mapper/... path) having potential corruption issues and that it’s advised that I run fsck /dev/mapper/... in the rootfs shell prompt that awaited me. I did this, agreed to all of the prompts about various issues detected and a recommended fix (just hitting y over and over), until it finished and I ran exit to reboot.

Note: it was super difficult to actually do an this (even after I found said hidden screen) because my keypresses were only being received at like a 40% success rate, where 60% appeared never to get through to the pty I was interacting with.

I’ll try to reply later with a transcription of some photos I took of my screen, so there’s more detail.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.