Cannot find programs after installing with Pamac


I just installed Manjaro on an old laptop with a KDE Plasma version 5.19.5, KDE Frameworks Version 5.74.0 and Qt Version 5.15.1

When I install a program using Software updater (Pamac) i can start it via “Launch” button in Pamac, however I can’t find it in Application Launcher (to favourite it for example and have it front and center), also the name of the app doesnt autocomplete in alt+f2 launcher, and in terminal.
I tried this with Chromium and AisleRiot Solitare, it seems that any software that didn’t come with the original intallation from USB doesn’t update in the Application Launcher and cannot be started via anything by Pamac.

Can I get some pointers as to what am I doing wrong?

Are they SNAP or Flatpak rather than regular repo packages?
(should probably show anyways … but those can act funnier)
And have you restarted session?

1 Like

Yes I have restarted, I don’t know it they are snap or flatpak I suppose not, It’s a fresh install I haven’t even enabled AURs yet.

It should be noted in pamac.

I guess I could also use pacman to look for chromium, which will only show if its a normal pkg, ex:

pacman -Qs chromium

After several restarts, and some time in the application launcher the newly installed programs showed up. I suppose it’s an issue with them taking a long time to be indexed by whatever part of KDE is responsible for indexing new programs.
So thanks four your help, the issue seems to have solved itslef.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.