Cannot exit from Boot menu

Hi !
I´m new Linux and have used it for a couple weeks.
I downloaded the KDE Plasma and it has worked just fune as I expected.
I dont have the latest stable version but the one before that.
Today I got lot of files for updating but I did not choose all of them.
After a restart I could get as far as the password site but no further,
So I did a restart and press the esc button to see if there was something I could do.
I choose the boot menu and tried to boot thru nb 1 Manjaro. But it did not work.
Now it is impossible to exit from the boot menu. If I shut down the laptop and
start it again the boot menu pops up. I then used Rufus and made a bootable
usb disk and it appears in the boot menu but nothing happens when I try to
execute the boot command. What can I do to get my laptop running again ?
Please advice a newbe like me .
Timo Nordberg

Huh? Do you mean you performed a partial upgrade somehow?

I didnt choose some program updates like webmail, printer and text programs but tried to include all that seemd to belong to Plasma libraries and so on.
So something seems to be missing :frowning: If I only could exit from the boot menu but I cant.
Could it help to rmove the battery for some time and then reinstall it ?

The laptop detects my usb device as nb5 but it wont use it to boot. It just blinks and jumps up to nb1 Manjaro.

@Erikxx, never try to exclude packages from updating it will break your system as you can see now. Especially, if you are new to Linux.

1 Like

Wollie, I see that now !
But I have to solve this somehow, just dont know how to get baco to “safe mode” menu from
the frozen Boot menu. I even tried with a win7 installation cd to if I could bypass the system but with no luck.
Thanks for your reply !
Maybe there is someone who know how to fix this even if it should be mean windows again. I can always go back to Linux after that.

Can I get pass this frozen Manjaro menu window and reinstall plasma or another Linux version ?
I would appreciate any help !

  • boot a manjaro usb
  • manjaro-chroot -a into your existing installation
  • complete the update:
$ sudo pacman -Syu

I wrote the text manjaro-chroot -a into GNU GRUB
the answer I get is : can´t find command ´manjaro-chroot´

Today I was able to enter Manjaros “safe mode” via fn+f2. I have also used Rufus to boot a usb from Manjaro website Plasma .iso file. But when I try to boot in the boot menu nothing happens.
With the command fn+f2 i get access to : Advanced options for Manjaro, UEFI Firmware settings, edit boot options and GRUB command line.
I´m a newbie to Linux :frowning:
Was right to enter the line in GRUB command line ? If not then I dont know where it should be entered.

This won’t work. The grub command line doesn’t give access to ordinary commands/programs (because the operating system isn’t booted yet) but only to select grub commands (which might help to boot the system).

I’m unclear what that means. Did you select a “fallback” entry from the grub menu and the system booted up?

Most likely fn+f2 brought up the grub menu (just like ESC would) and you’re seeing its options.
Yoy can try to choose any Manjaro option to try to boot up the system to a state where entering a tty would be possible (ctrl+alt+f3 for example) so you can login there and try to fully update the system.
If none of the Manjaro options get you far enough, you would have to try the “booting from usb” route I described earlier.

OK thanks for your reply.
I will try it again but but booting through usb or the other alternatives in the menu just make the screen to blink once and the menu is back again.
If I do a normal start of the laptop it gets me as far as to the password page and when I enter the password another page appears where I can see that it is trying to load Plasma but the the loader sign freeze and nothing more happens. So here is the spot where the system cant go any further, if you know what I mean.

This is the place where you don’t try to login on the login screen but switch to tty like described above and issue the full update from there.

I went through the procedure described in the link you attached and came all the way to where I was to give my username and password. Username went OK but I wasnt able to insert my one digit password nomatter how I tried. I went through all kind of possibilities but the password area was blank. By the way I was directed to tty1 on all my attempts.
I must thank all of you for your kind help and advices but dont see anything else to do than buy me a new harddrive.
Thanks again !

It should be blank. Just type it correctly and hit enter.

But it remained blank whatever I did. Couldnt insert my one digit password :frowning:

I did hit enter several times after inserting the password. I have only one digit so it should be easy.

Hm. I am thinking this is from runlevel3 or TTY …
I am not sure … it could be a keyboard/language problem - thus preventing correct input.
The chroot method may produce better results … have you tried that?

Also I shouldnt ignore this. thanks for the thanks :slight_smile:
Hopefully we can get you sorted.

I dont know if I understand where to insert “manjaro-chroot”

You would need to boot from a live-usb and then run it in a terminal from there.
manjaro-chroot will then allow you to log in to your HD system from the USB desktop.
(and perform whatever troubleshooting or fixes)